2DFighter Port Help!


#1

Hi,

(I know I’ve posted this as a reply in another thread, but I’d thought I’d start my own, to hopefully get someone’s attention)

I know this has been done to death and asked a million times, but I need help with hosting (on 2DFighter). Ok, here’s the all IMPORTANT info:

  • I use Windows Vista, and the emulator runs fine, etc (just hosting issues lol)

  • I connect through a router and have the option of either wireless or wired.

  • the router is a Belkin F5D7234-4 v3.

  • I run Norton Protection Centre/Anti-Virus/Internet Security.

  • I’ve gone into the Router page, into Virtual Servers under Firewall, and set up 2DFighter on Port 27886 and UDP.

  • I’ve gone into Norton Internet Security and changed the settings for 2DFighter, and made sure it accepts in/out bound connections to and from other computers, selecting again Port 27886.

Now, whenever I log into 2DFighter, I click the Host Test button and it tells me “Congrats… etc, you can host”, and ONLY SOMETIMES can I play people who cannot host. Most of the time, I’ll challenge my good friend who lives in the same country as me (UK) and half the time it won’t work, only sometimes does it work. (Edit) I forgotten to mention that when it doesn’t work, the emulator screen comes on (white, with the logo), and there is a message in the corner saying 'Waiting for Player 1/2" and it just stays there and nothing happens.

I constantly check my IP address, to make sure it is the same (it is not a static IP address, I don’t know if that matters, but surely if I check each time what it is, and make sure the port is open to the same one it shouldn’t matter, should it). Someone mentioned that because we share the connection (with my family), that there in lies the problem. I’ve gone to PortForwarding.Com and tried so many different things. Why is it that I can use Steam to play Multiplayer games no problem, but an emulator, loads of problems (that’s me being cynical).

Also noticed this error when I try to play someone sometimes, and the Splash white screen just appears, I click on Test Host button, and this error comes up:

"Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

Only one usage of each socket address (protocol/network/port) is normally permitted."

WTF else is using Port 27886? This is ridiculous. It doesn’t make any sense. I’ve done everything I can think of. And even turning off Norton dsoesn’t change anything.

if anyone has any suggestions, or can help, I would really appreciate it, my Gamepad is just sitting there, not being used!!!

Thanks in advance,

Lewis