360 Fight Sticks doesnt work on pc!


#1

hello guys i have two fightstick (ps3 -360) and i just bought a laptop(Win7 64) . Ps3 fightstick works fine but 360 stick isnt work ! i have tried xbox wired controller driver but still doesnt work ! lights off buttons doenst work windows doestn recognize fightstick !

What i have to do ? i need help

Regards from istanbul …


#2

Hmm, mine works with the wired xbox 360 controller driver. Are you sure you’re using the right one?


#3

yes im sure
http://www.microsoft.com/hardware/en-us/p/xbox-360-controller-for-windows#support

i downloaded and installed 360 stick works fine on xbox (i also tried another 360 fightstick , same stuation )
ps3 stick workin but 360 not !! sounds so funny i need help guys !!!


#4

so ?


#5

Isn’t this connected to the old USB 1.0 =/= 1.1 problem? If so, then it’s your motherboard, to fix that problem get a USB-Hub that supports USB 1.0 (Via Chipset?)

Next time use the search, there should be a ton of threads for this problem, also i wouldn’t double post, some mods on here are really anal.


#6

If you’ve downloaded all the correct drivers, that your USB port is the problem. You may have a shortage in your hub, and all it’s able to do is recognize that a device is plugged into the hub. You can try to reinstall the drivers but if your usb ports aren’t correct, it doesn’t matter.


#7

i dont understant if problem is usb ports why same ps3 fightstick working well ? this new pc using usb 3.0 hardware maybe because of this ?

@BerlinCalling

i already searched ton of threads believe me … spent 2 days !


#8

cmon guys !!


#9

I don’t think I used this driver, but the comp I had ggpo on is messed up… I’ll find out what driver I had later today when I get home from school.


#10

Which arcade stick is the 360 one?


#11

MadCatz SSF4 FightStick TEs (360)
i also tried madcatz 360 brawlstick… no recognize …


#12

Format you pc.


#13

can’t be serious ! its already a new computer , bought this week…


#14

I’m serious.
A friend of mine had problems with some drivers.
Even that the windows was fresh.

It works on other computers?


#15

yes works fine on other computers and consoles , i dont know must be other ways ! i spent fuckin 3 days for it gonna be crazy soon !!!


#16

Did you try a USB-Hub yet?


#17

no not yet … im going to buy tomorrow …could usb hub help my problem ?


#18

Could solve the problem, make sure the USB-Hub supports USB 1.0 and 1.1/2.0


#19

thx berlincalling im going to let u know if it work


#20

i tried same same same