[360 Stick-Building] Triggers are Messing Up the Game


#1

So we’ve been building an Xbox 360 stick built from a Gamestop controller and had errors in Windows 7 where the game either wouldn’t read the triggers (Skullgirls, Jamestown), or it would read the triggers but the other buttons won’t work (SSFIV: AE, SFxT). When I go to check the game controller properties to test the buttons it seems to work just fine, but in the game it starts to mess up. The thing is even though this is a third-party controller, it was working just fine when we tested the controller before wiring it to the stick (I tested it in every game I needed it to work in before we started wiring). We had wired another controller (third party but a different brand [Afterglow]), and had the exact same problem. Unless this has something to do with all third-party controllers, I don’t think it has to do with it not being name-brand since the controller had been working prior to wiring.

We think it’s the driver, but it could also be the fact that we cut the USB cord and and re-wired it back together again so that we could fit the cord in an opening on the back of the stick. I don’t claim to know what the problem is, but I hope to find a solution soon. Right now I’m trying to find the driver that goes with the controller (TSZ360 Gamepad, right now it’s on the official Xbox 360 driver [Xbox 360 Controller for Windows]). If you need pictures, I’ll certainly post some.


#2

How is the triggers wired?

Photos of your work will be helpful.


#3

For both triggers, we soldered a resister between V and Signal, and then another resister between Signal and G. [Here’s the post that helped me with this.]([Stick-Building Question] Can’t Wire Triggers

Here are the triggers:
http://imagizer.imageshack.us/v2/xq90/843/5dfmj.jpg
http://imagizer.imageshack.us/v2/xq90/838/0dka.jpg

And here is the USB plug:
http://imagizer.imageshack.us/v2/xq90/836/8stj.jpg


#4

The resistors are done completely wrong, the resistor needs to gap the two solder points, you have just straight wire there.

it should look like this


#5

Sweet Jesus, what the Hell is going on with those resistors??


#6

Okay, we’ll certainly find a time to fix that! Sorry if it’s a little messy, we weren’t exactly shooting for cleanliness when we were setting it up.


#7

The mess is besides the point (but it should be addressed at some point)

Component placement on a circuit what is critical.
The Resistor is taking place of the potentiometer you had removed.
As in the photo I showed, the resistor needs to go between the base (bottom) terminal and wiper (Middle) terminal.

What we are doing is tricking the PCB to think that the potentiometer is still there in the “neutral” position.
When we but a switch (a arcade push button is a switch) in between the top terminal and the middle terminal We are trying to mimic that potentiometer as a full squeeze on that trigger.


#8

Right now we are trying to fix the stick. What is the value of the resister used in the picture?


#9

Looks to be a 5.1K


#10

#11

Ok, so today we finished the first trigger, and we should be finished wiring the other one around next week. We got confused, because the other person we had help from seemed to had said that we needed to wire two resisters instead of one and that we needed a 10k resister. Apparently that doesn’t seem to be the case, but now it seems we’ve got it working!

If we have any problems wiring the next one, I’ll certainly let you know.


#12

Alright, we wired the arcade stick just like you said (only we used 100k resisters. Our wirer, Micheal, thinks that is what is used in the picture [from left: yellow, black, violet] and that that is what is best for the arcade stick). Similar to the problem that we originally had, it works great in the properties menu of the controller, only once the game starts running it stops working. It is different for every game. In Skullgirls, LK LP and MP are held down. In SSFIV AE, only the triggers work. In Jamestown, the triggers will only be pressed if they are unpressed and vice versa. Again, it will seem like it is working when we test it in the device menu, but it will stop working after the game is loaded (only the menus will function). Other then possibly a wiring mistake, we have no idea what the problem is.

I will post pictures of how we wired them. Please note that the wiring for these is by no means final until we can get the triggers running properly.

http://imageshack.com/a/img822/29/n467.jpg

I’m sorry if you can’t see this properly, but the wiring for this one is under the controller board.

http://imageshack.com/a/img819/4575/4mdm.jpg

This resister is underneath the black tape.

http://imageshack.com/a/img829/264/ld2i.jpg

If you need any more pictures, let me know.


#13

We’ve been trying to look into this problem for a while and we’re stumped. Getting an answer - any answer - would be extremely helpful.
Thank you!


#14

i don’t know if that’s the problem, but according to slagcoin, 100k is way,way too much…
slagcoin recommends a 5k resistor which is optimal for not affecting the current in the board,like i said…i don’t know if that’s the problem but do check it out.

http://www.slagcoin.com/joystick/pcb_wiring.html#PCB_COMPONENTS_MODIFICATION_AND_REMOVAL

i neutralized a variable resistor (but for the analogue sticks though) using 2x4.7k resistors with the help of that link i shared…Triggers need only 1 though and it’s supposed to be easier than analogue stick neutralization overall.
at my side, it worked like a charm…first time,too


Can't neutralize the triggers on the 360pad, sure i have the right wiring
#15

Thank you for the link! We will certainly find a time to try the 5k resistor and I will report back with the results.


#16

After trying the new 5k resisters on our controller, it still wouldn’t work. We came up with an idea of keeping the potentiometers in the controller, and to do that we would need to buy a new one. We didn’t want to risk the idea of a third-party controller driver not working, so we bought a first-party one from Microsoft.

We initially wanted to wire resisters, but found it worked just fine without them. We wired the wires into the middle and bottom ones on the three holes for both of the triggers. After testing all of the buttons in the games, we have concluded that it works properly. No more buttons not working and whatnot.

Whether or not this would have worked with the other controllers we don’t know since we’ve only worked with the potentiometers now without disconnecting them. The important part is that we’ve got it working. Thank you all so much for your help with this. Even if we found the answer ourselves, we wouldn’t have found it without you guys.

Sorry for all of the bumps over a 3 month period. We can only work on this controller when Mike and everyone had time to (around bi-weekly).

Final result:
http://imagizer.imageshack.us/v2/1024x768q90/908/XPDXun.jpg