360 TE Stick not working quite properly...is this normal?


#1

Hi there folks!

After a long wait, which was about one month, my girlfriend was finally able to give me a brand new SF4 MadCatz TE Stick for my birthday yesterday (nobody wants to know, but I’m 24 now. Hooray for shameless self-promotion! Anyway, back to the thread).

So today I got home and first thing I tried of course was to plug it into my 360 (for reference: I put it into te 360 via each of the fron USB ports, no usb hub or anything). I pushed the Guide button to boot my 360, which worked flawlessly.
But then I couldn’t move through the Xbox menu. The buttons themselves worked flawlessly, each and everyone of them.
The stick itself also works flawlessly in any game I tested it on (which are only SF4 and SSF2THD for now, will test it soon on VF5, MvC2 and a few others).
Also when I’m in the Guide menu I can’t move the cursor either. The joystick just won’t respond, only the buttons do.
I also tried using the stick as left analog, right analog and D-pad. Neither worked.

So, as asked in the thread title: Is this normal?
I mean, as said it works flawlessly in either game I tested it on for now, but I find it quite irritating not being able to move the cursor in either of the Xbox menus.

tl;dr version:

  • Got a new TE stick for 360 for my 24th birthday, which was yesterday.
  • Cursor doesn’t scroll through either Xbox menu when using the joystick, though every button works flawlessly.
  • Switching between left, right analog or d-pad doesn’t do crap.
  • Aside from that the whole stick works fine in any game tested (SF4 and SSF2THD for now).

Please help me, guys :frowning:


#2

It should work in DP mode in the dashboad. If it isn’t, it is possible the switch is somehow stuck in LS, which would mean it would work in those games, but not necessarily with the dpad logic that you want, it is probably using LS which emulates the left analog via the digital switches.

You should try a game that uses the left stick, dpad and right stick for different things (like an fps) and see if that switch is actually properly switching between them


#3

Yup, you’re right. I just tried it on Perfect Dark XBLA in the Carrington Institute and all I could do was move around, regardless of which setting I put the switch on.

Well that…sucks a little bit. Is there a way to fix this easily without having to send it to MadCatz for repairs?


#4

i believe the dp/ls/rs option is all handled by the pcb, which unfortunately means getting madcatz to repair it.
unless there’s something obviously wrong with the switch, i’d just put it down to good old fashioned low quality madcatz pcbs.

you could always replace the pcb completely, but usually that would mean losing the dp/ls/rs option altogether.


#5

Well if you’re confident you can remove the cover panel with a hex key (the size that comes with smaller ikea stuff fits) and remove the two screws (and the red gunk on them) to open up the turbo panel.

If you open up the turbo panel you might be able to see something wrong with the switch. Maybe the metal connector has fallen out. Is there resistance when switching in between modes?

Unfortunately that would probably void your warranty, so it might just be best to get madcatz on the phone. However if you’re actually in Germany the repair process might be slow. In Canada they wanted me to mail my TE to the states which would have taken forever and cost a fortune.


#6

Maybe your girlfriend can take it back and get a replacement from the store she bought it from.


#7

Returning it would probably be the best.

If you are going to open it up, here is a video of opening the turbo panel. You do not have to rip your TE completely apart like in this video to get to it. You just have to take the cover panel off.

[media=youtube]2Zy5mGnzMCc&feature=related[/media]


#8

Just send it back, it’s the safer, more reasonable choice.


#9

Well, since I’m stupid as hell and didn’t think about voiding my warranty when opening things up (I really hate that square gate, and really love my octo gate), I guess I’ll have to do things by myself or let them be as they are.

I mean, it’s not THAT BIG a major flaw. I can work around it. Even if that means that I’ll have to have my normal controller ready for reading messages or turning my console off :smiley:

Thanks anyways, guys.
Special thanks to you, JMro, for the Youtube video link. It’ll eventually become quite helpful once I’ll go all out and customize the shit out of my stick :wink:

Also, to answer some questions asked:

  • My girlfriend got the stick via Amazon. I don’t know if they would somehow notice that I already made a small modification (which is always easily reversible), but I will definitely try to get in contact with them.

  • The switch does have some resistance between switching modes. Just as much as the (working) switch to deactivate the Turbo and Guide buttons.

That’s all for now.