360 VLX RJ-45 MCC dual mod success!


#1

Well I’m wondering if anybody else has attempted to dual mod RJ-45 a 360 HRAP VLX

I ran into a problem that seems to be strange. I accomplished the mod and the 360 PCB side works fine on PC and does not work on the xbox 360. The MC Chtulhu works on PS3 fine so far, but have not gone through the system wringer for testing.

If you have done this mod on a VLX and have no problems please chime in.

Here are some photos of how I did this mod, I tried to not void the warranty.

Using an Imp+MCC+VLX 360 pcb and RJ-45ing it.

I made a custom harness out of two speaker wire headers to tap the USB lines from the PCB for Voltage, D+, D-, Ground

Since I refuse to mod the case in any way I am using a Ethernet Coupler instead of a Neutrik.

I figured out what end of each button wire is the signal and made an intermediary connection to avoid having to open the black box. Screwed them into the MCC screw terminals.

Ascii Optical. Made some PCB adaptor to plug into the default harness and have lead wires to bridge to the MCC screw terminals.

It seems to be working fine in Windows 7… But nothing on xbox 360. Cthulhu worked on PS3.

I’m out of ideas on what to trouble shoot. If anybody else does this mod with the VLX PCB, could you please post the results in here? I’m probably going to get a 360 fight pad pcb for this to work.

I am going to experiment with dropping the imp for an internal dpdt switch.


#2

Now working with DPDT switch

Installed a DPDT switch. Put the switch in a Project box and then used Velcro to secure it.

Two strips of velcro on the inside of the case.

I can also put it up vertically

Wiring is messy as hell, Maybe I’ll clean it up later…maybe. So if something dies on the Hori PCB, I still have my warranty sticker intact, and I’ll be able to put it back the way it was.

It probably turns out that my imp chip is faulty. I wish there was a trouble shooting guide for it.


#3

Now I finally found a use for those project boxes (thanks rtdzign). And now i don’t have to put an unnecessary hole in the body of the stick.


#4

Radio Shack project box. The other thing was actually a ethernet coupler, got it for like $3 at Fry’s. Yes please keep her a virgin, no need to drill her hole.


#5

So you solved the 360 issue? Was it that you had to replace your IMP w/ the DPDT switch in your project box?

You didn’t ask Toodles’ for any help w/ the IMP?

I was thinking about just pulling the signals/power off the USB cable itself rather than opening the PCB box. Glad you confirmed for me that’s an option.

I think I’m going to go the ChImp route since I don’t really care about anything but PS3/360 (have too many other MCC sticks :stuck_out_tongue: )

Great job on keeping your VLX virgin. :slight_smile:

Oh, so now that I’ve thought about it, I have one question that I can’t answer by looking at your pictures:

You didn’t connect the USB input to both the VLX PCB and the Cthulhu? You’re not using the USB cable that came with the VLX at all? You’re just sending the Ground, Power, and Data +/- lines from the Cthulhu to the VLX PCB using the custom cable?


#6

Removing the imp fixed the problem, but after running multimeter tests on the imp, the imp appears to be working. So I don’t know but my stick works fine now and isn’t broke so no need to fix it.


#7

Haha, I thought this was great and almost so dirty at the same time. I wonder what Hori would say if they saw your OBSC-30s and ascii. And good thing you covered up those “nipples” this time around. After all, we’re supposed to be more or less family friendly. And that thing is just too hawt to be showed. XD


#8

That is correct. I got some header pin connectors at frys to tap the usb port. the ground and voltage linked to the mcc and d+ d- go to the dpdt switch. I’ll take a photo of the cable that i got 2 of for the custom harness.

Edit:
So i picked up two of these. Because I could not find superglue, I used heat shrink tubing to stick two of these together, and cut off the other ends and used those wires for the usb port. These things are the only thing that I could find to fit that proprietary 5 pin sip header for the USB connector.


#9

I just ran into the same problem that you had with the imp. 360 works fine on PC but not on a real 360 system and PS3 works on both PS3 and PC. Only thing different is I’m dual modding a Hori Fighting Commander 3 pad with a 360 TE pcb and Imp.

whats the full code on the 4066 chip on the imp that you took out?


#10

Perhaps Hori PCBs are touchy when it comes to the Imp? Speculation: having to do security confirmation?


#11

I just swapped the imp with a new one and now it works. I believe its a issue with the 4066 chip. I think Toodles had a similar problem with the 4066 chips on the chimp causing him to use a better quality 4066 chip.

Edit: The 4066 chip on the imp that had the 360 problem is “M74HC406681” and made by SI?


#12

I reused that imp board that had the 360 issue while with the hori pad in a MC + madcatz 360 pad dual mod and it worked fine. weird.


#13

sorry for the late response. Yeah my chip is the same. It is also made by SI or ST. I would have though that the logo said ST.


#14

so the verdict with the chimp is pretty much luck? or are all the new ones are made with better 4066 chip?


#15

any plans on a tutorial for this? :tup:


#16

I already made a dual modding tutorial for MCC-RJ45. This one is just routed differently.


#17

I was wondering if you were going to do a “non soldering” way to keep the warranty.


#18

Instead of soldering to the Xbox mobo I tapped the signals from the default quick disconnects. That is the only difference.

I made wires that had a both a male and female end. I put the female on the button the male on the original QD and the end of the wire to the cthulhu.

I still had to solder guide and select to the daughter board.


#19

i see, so theres no way around it. Even a tiny bit of soldering is required

Thanks for the quick replies


#20

So after fiddling around with the vlx today, using a combination of MCC + Imp + hori 360 PCB. I ran into what it seems like the exact opposite of what Rtz had run into.

Everything works fine and dandy on the 360 version, but when I plug into the PS3 I get an “unknown usb device” error.

weird how ive been reading on how other ppl have been getting the PS3 versions to work and not the 360.

any thoughts on why mines is ass backwards?