360 wireless controller problem.


#1

I’ve got a problem with a wireless controller I’ve got, basically it doesn’t charge the battery that’s in it. At first I thought it might have been the battery, then the P&C kit, but after swapping things around, it seems it’s the controller that’s at fault.

As soon as I plug the USB cable in, it lights up red for 10 secs or so, then turns green indicating that it’s charged, when it’s not! I tried cleaning the contacts but that didn’t fix it.

Any reason for this to happen or do I just have a dud controller?

To make matters worse, it’s the one that’s in my arcade stick so it’s a bit of a pain having to pull the back off it in order to swap batteries, but I guess that’s cheaper than replacing the controller PCB that’s in it.

Has anyone else had this problem and fixed it?


#2

I’ve seen batteries that wouldn’t charge before, but it’s always been the battery at fault (corrupt EEPROM data) never seen a controller that’s caused it before and I’ve seen quite a few controllers with problems. :wink:

Is this the older Matrix board or the newer CG one that is suspect?

If it’s the one in your sig it’s the CG, so that kinda makes it a little more difficult to troubleshoot as it hasn’t really been out as long and I haven’t seen any of that version with issues yet.

Nothing has been knocked off the board has it?


#3

Hey RDC, yeah it’s the same CG board as the one in my sig (same stick) and nothing has been knocked off the board. Well not that I’ve noticed anyway and I’ve very careful.

It was working, charging batteries properly, but I haven’t used the stick for a while and have only started using it again (due to Soul Calibur IV) and since then I noticed this problem.

I’ll keep mucking around with it and it might right itself, unless you discover something that could be the cause.

btw, the pics and info you posted on Xbox-scene were awesome, they really came in handy. :woot:


#4

I should have mentioned before that usually if the battery is the problem ya don’t get any light at all from the PnC kit, so I’d rule it out from the sound of it, but I’d still try others and from the sound of it ya have already.

Aside from the PnC kit being the problem or something in the wiring there that has me a little puzzled, but I’ve yet to see any of the CG boards start having issues, this could just be the first of them is all. I’ve seen all kinds of issues with the older Matrix ones and fixed more than a few that would have went to the bin, but the CG seems to be a pretty good board so far as reliability goes.

You’ve tried another unopened, confirmed working PnC cable? I noticed from the sticks build thread ya pretty much kept the board and PnC setup fairly intact, and I know ya mentioned the PnC kit, so plugging in another one wouldn’t be to big a deal.

Any way ya can plug up another Wireless controller to the PnC kit in the stick for a test there as well?

The PnC cable seems the most likely culprit to me, that or the wiring/connectors of it somewhere. It’s pretty much just a 3.3v regulator and a voltage comparator to know when the thing is charged and change the color of the LED once the battery is full, so it thinking the battery is full too soon really points more to it being bad, though the problem could still be on the controller board somewhere, I haven’t gotten into that circuit on the CG board like I have on the Matrix one, yet. :wink:

If it doesn’t resolve itself, really would doubt that, though I’ve seen weirder things, and ya decide to replace it and the new board works let me know about the old one, I’d be interested in taking a look at it to see if the problem still exists in another setting and what it may be.

Thanks. :wink:


#5

Yeah I tried that, I flipped the stick over took the battery and P&C kit off the sus board and plugged them into one of my other working controllers and the charge light stayed on as if the battery was being charged.

I also got my other good P&C kit and battery, plugged it into the sus board in the stick and after 10 secs it went from red to green.

Very weird. Trust me to get a moody controller. :rolleyes:


#6

Just an update…

After playing Soul Calibur IV for a few days and draining the battery a little (different one to before), I plugged the USB cable in and the thing started charging! So I don’t know what the hell is going on.

Although it might still be a battery fault of some sort as after I plugged that battery (original I thought was sus) into another controller it didn’t seem to charge properly, in that the red light of the P&C kit came on but it seemed too quick to charge.

I will keep testing and if I come up with something concrete, I’ll post my findings here.