A button on my stick is firing without being pressed


#1

Got an Arcade-in-the-Box stick some time ago (like a year or so ago). Works great. It has seen heavy use, partly from myself and partly because I bring it into the office for lunchtime STHD with colleagues.

Lately, my MP button has been occasionally firing without being pressed. I’ve confirmed, along with another person, that the button wasn’t pressed when suddenly an MP came out on screen or a character was abruptly selected with his MP color.

How do I resolve this issue myself?


#2

Which system is it for? Which button (triangle, Y, etc.) is it on that system?
Open 'er up, remove the wires from that buttons microswitch (you may have to desolder if they’re soldered in place), wrap the exposed signal wire in electrical tape so it can’t accidentally touch anything, and let it sit in training mode for a while and watch if MP ever comes out. If it doesn’t, you need to replace the microswitch (American Happ buttons) or replace the button (Japanese parts. Technically, you COULD replace just the microswitch, but most folks swap the whole button.


#3

Check the wires connecting to the MP button. The ground and signal wire may be touching at either the button level or the PCB level. Or there may be a loose ground touching the signal wire of the MP button. Check all connections.


#4

Swap out the button with one of the other buttons in your case. If the other button is activated without being pressed then you can replace the switch with another one. If you swap out the button and you still get the same error and then check out the wiring and make sure nothing has come loose.


#5

This is the best couse of action to take and it will take a little more work than what I described.


#6

Thanks for the advice; when I can I’ll open up the stick and see what I can do.

I have no man skills, though. Well, very few: I can operate a screwdriver, build a PC, even replace a tire, but soldering is beyond my skill set. Other than learning (I’m very lazy), what can I do if I see that soldering/desoldering is necessary?

360, and the Y button. Buttons are concave American-style.


#7

take it to your friend and ask them to solder for you?
I can’t think of any big store that would do soldering for you (maybe, maybe your own local, small electronic shop)
but really… soldering is not hard, if can build a pc, replace a tire, soldering shouldn’t too difficult since you already have the patience to learn how pc works…


#8

When I rebuilt my MAS to work with the 360 I had tons of problems like this. Even though it is the 'Y" button acting up it may be another wire causing the issue. Can you post a pic of the wiring? I found that the anything with the guide button or especially the triggers (which need resistors to work) can cause hell with that PCB.

Anyway, Y on the older wireless PCB shared a common ground with 4 other buttons. On the wired pad, it shared a ground with the back button. Post some pics, Im pretty sure they used a MS wired PCB.


#9

I was surprised to see that AIAB solders directly to the buttons instead of using quick disconnects. He may not be able to easily swap the buttons without de-soldering them. Once you open the stick see if there are little solder blobs on the connectors for the buttons.


#10

Is that an MS pad? Doesnt look like it.


#11

Nope. It’s one of the newer common ground Mad Catz GameStop pads. I just wired one of these up with a PS1 PCB and it worked great.


#12

Very late response. So I busted 'er open. Four pics to follow. Low quality ones taken with a friend’s iPhone. If necessary I can get more HQ ones.

I noticed that the wire for the X button did pass rather close to the Y button, so I carefully bended the wire away from it. I’ll check tomorrow to see if the wire retook its old shape. You won’t see the bend in these pics; I did that after.

Learned alot just looking inside that thing. A while back my roundhouse button was loose so I super-glued it down. When I opened the case I saw the rings that screw in and secure the button. :rofl:

Anywho, pic 1:


#13

Actually, no need to upload all 4 I think; each pair looks identical.

Pic 2:


#14

Did you try disconnecting the wires, swapping the buttons or anything else yet?


#15

No. That’s all next all the list if what I tried fails.


#16

Bending the wire out of the way did the trick… for the Y button.

Now the left bumper (LB), my Fierce button, is misfiring, and the Y button has never done it again, which I find bizzare…

I’ll be moving on to the rest of the suggestions in this thread. Thanks again for all the responses!


#17

Pardon the thread necromancy. The issue was still happening with the LB button sparingly, but reach a point where it was only misfiring if I hit X or Y (so in SF4 I’d get an EX move with one button sometimes). I tried switching the buttons around and same thing.

I was thinking of getting some Happ convex buttons anyway (I think I may have outgrown concave) so I’ll see how those buttons perform.

Thanks again for all the responses.