Absolute Question and Answer Thread (ASK YOUR QUESTIONS HERE!)

Gotcha. Just making sure. USB cables are super cheap nowadays so didn’t want you wasting money haha.

Yep. You can hook a ps360 -> cat5 -> neutrik/switchcraft passthrough -> console cable, or ps360 -> console cable. As for the dual mod, it should work.

I’m about to mod my stick for the first time and i was wondering when I buy buttons online it comes in a pack of 6 right?

Unless you purchase a pack of 6 then you will need to order 6.

Been lurking around this forum for a long time and finally decided to join. I have a question for all of you fightstick masters. Decided to ditch my fight pad and upgrade.

I tried to find information on these sticks in this thread but could not find much. Sorry if I missed anything. What would be the most reliable between Eightarc Fusion Synthesis, Mad Catz Arcade FightSticK PRO or Major League Gaming Arcade FightStick: Tournament Edition?

Any feedback would be appreciated.

You’ll want to read this thread first…

There’s a lot of information there, especially if you think that you may want to venture into modding later on. Your question is almost the equivalent of a “vs.” type query, which is frowned upon. In either case, the thread above is a good head start and might help point you in the direction you want based on your needs now and later - believe me, it’s easy to get hooked on sticks. My collection is already up to 4 in a few months. One is already modded, and I’m working on the second one right now! Let’s not even talk about the collection of parts I have for tuning, lol.

Also be forewarned that it takes a while to get accustomed to a stick. I’m still struggling a bit myself, but I’m getting used to it.

They’re all quality sticks and it’s hard to go wrong with any of them. It comes down to price and aesthetic preference at that point. They all use the same parts, except the Eightarc is dual modded out of the box.

Thank you PlayDoh003 and SmokeMaxX for the information and advice. I will study these sticks a bit more before pulling the trigger on one.

I got a fairly crappy stick about a year ago to tide me over until I had the money for a real one. I’ve since put some sanwa buttons into it, but the USB chord has some sort of connection loss in the middle of it (twisting around until eventually connects, ect). Where can I get a replacement chord? (for PS3, btw)

Any USB cable will be good enough. Grab a new one (make sure it’s long enough for you, 6 feet at least) and snip off one end, remove some cable sheath and the shielding (silver material) until you got the 4 wires. Open you case, find where the USB cable is attaching, remove it, attach the new one, game on.

Alright, thanks a lot!

EDIT: Wait, will I need a soldering gun for this?

Yup…very easy install…

Well, off to the friends to borrow the soldering gun, then.

Alright, So I’ve bought myself a Tekken Tag Tournament 2 Tournament Edition S+ for 360, dual modding it with a Cerberus PCB. Got it all wired in, plugged it in a playstation, the player indicator blinks and i cannot get anything with it, does the same for PC, but it doesn’t recognize it. I feel like I’m missing somthing stupid here.

Hey everyone, I have a quick question. I’ve been trying to find the answer out, and I’m pretty sure it’s yes, but I want to double check.

I ordered the SANWA DENSHI JLF-TP-8Y-S Silent Joystick from arcade shock and it’s being delivered today. Is the replacement of the joystick as easy as the buttons? Is it literally just unplug the old one and plug in the new one? I noticed it comes with a wiring harness, but I’m unsure if it’s the same cable that connects to the joystick from the PCB.

Thanks for your time.

Sounds like you might not have got the data cables fully seated. First step that I would try would be to completely redo the USB connections for both the XBOX > Cerberus and Cerberus > Out cables.

Undo both the USB connections. First attach your Cerberus > Out cable and plug it into your PC and see if you get recognition (no ribbon cables connected). Then go ahead and hook up the XBOX > Cerberus cable (Don’t seat it into the sockets or attach ribbon cables), plug it into PC and see if it recognizes it still. Next connect the ribbon cables to the Cerb and test PC, PS3. Finally seat it back into place with the XBox pcb and test everything else out.

If you have problems again, following those steps will be helpful in isolating where the issue is.

A little extra work here. This joystick features independent switches that you will have to connect individually. You will use the provided harness which will then come out to a male 5-pin connector. You’ll be attaching this male 5-pin connector to your existing 5-pin female harness in the stick.

You’ll need to take care that you connect the microswitches correctly. Take a look at this diagram from Akishop to assist you in making sure you connect properly.

If you’re not sure how to orient for your current 5pin harness you may need to look at your stick’s PCB - the silkscreen should help you determine which wire is intended for which direction. But if you mess it up it’s easy enough to unplug your QDCs and redo them.

After pissing around with it for two hours, I stripped the wires back and doubled them over because they weren’t getting enough of a connection

I’m assuming that after blinking briefly the light goes out?

Double check the USB wire connections both coming from the XBox360 PCB and the one coming into the stick. Can you see the wires through the little holes on the clamp connectors? I would also double check that the Cerberus is well seated.

On PC, it’s normal for the light to go out, if the Cerberus takes control. If you force it into 360 mode, the P1 LED should blink once, go out briefly, then blink a few times and stay on. This confirms that it’s in 360 mode. On PC, go to Devices and Printers in the Control Panel (assuming Win7), and check if you see “Cerberus v1.01”, or something like that. In XBox360 mode, it will identify itself as a “Mad Catz TE-S”, I believe. In either case, if you see that, you should be good. If not, again, check the USB connnections, and double-check the seating on the plugs and the Cerberus into the PCB plugs.

I did the same exact dual mod, and ended up putting a zip tie along the left side to keep them well seated for good measure. Haven’t had an issue since. :slight_smile:

no worries man. i said forget it and took apart one of my sticks that had the LS-33. Took and replace the microswitches instead =/.

Hi Folks, I have a madcatz se fightstick for 360 that i overhauled with sanwa parts a while back and everything was working great on it until the other day i went to plug it in and and it was not recognized by the console and the four lights around the home button on the stick are all on and solid, not flashing like it’s trying to sync with the console. I opened up the stick to check for any loose connections and there didn’t seem to be any, but jiggled some of the cables, plugged it back it and it worked, so it did seem like something was loose.

Anyway, it’s doing the solid thing again and the jiggle trick is failing. Anyone have any insight to the solid ring’s meaning beyond “not working”? After a few days of googling, I found “not enough power” as a possible solution, but I’m not sure that’s issue since it was working fine for a while and the usb connections to the pcb look fine and wasn’t one of the cables i jiggled, and my other sticks all work fine in the same usb ports. Thanks for any help with this.