Absolute Question and Answer Thread v.3 (ASK YOUR QUESTIONS HERE!)


#41

I’m apparently an idiot and can’t find ps360+ firmware 1.5 hex no matter how many search engines I blaze up.


#42

It’s here, you have to scroll the On page menu down to find it: http://www.akishop-customs.com/PS360Plus.html


#43

Assuming that the Atrox board is common ground, would this be the appropriate way to try and hook up an MCC + IMPv2 to it?
i.imgur.com/igAN1Gn.png


#44

Yes the Atrox is Common ground.


#45

So hooking up the MCC+IMPv2 like that to the Atrox should work, right? Is there anything special to be aware of regarding the existing USB port on the Atrox if I plan on using an ethernet coupler from the IMPv2 board or can I just ignore the Atrox USB port?


#46

That I can’t tell you, the experience I had was on the Beta version of the Atrox not the final retail version.
They did made some changes from the Beta and the Final version of the stick.

I am hoping someone else on the community chimes in, as I don’t want to lead you astray.

You can read though The Razer Arcade Stick Thread! for more info


#47

Figured I’d post here before going ahead and making my own thread, please advise if a thread is necessary.

Around 3-4 years ago now I purchased a custom stick w/ RJ-45 and MC Cthulhu support for Xbox360/Ps3 support. By default the stick would register as a 360 stick when plugged in and to switch to “Ps3 mode” I was supposed to hold the HOME button on the stick prior to plugging the USB end of the cable into the console. The problem: the non-360 part never worked -except- for one instance in which I was able to get it working for a period of a few hours on my Ps3 after which I was never able to replicate the feat (Went to bed, turned the console off and nada the next day). After sending it back to the individual who made the stick three separate times (And receiving about five new USB/RJ-45 cables over the course of those three shipments) the guy swore that it still worked on his Ps3. After 3-4 years of on and off still vainly trying to get this thing to work properly I am a bit skeptical that user error is the issue but I guess nothing can be ruled out and I am not above trying yet again.

I no longer have an Xbox360 to test the stick on so my efforts have all since gone to trying to get it to work on my Ps3. When I plug the stick in to my Ps3 after holding the HOME button I can see what appear to be lights beneath the top of the stick flashing (Beneath the buttons), but nothing else that gives me any indication of what might be wrong. If someone could give me some guidance or troubleshooting advice I’d appreciate it (Or if more information is necessary to diagnose let me know).


#48

I would try a dual pole, dual throw switch rather than the imp board to see if that’s where the problem is. That said, if you’re not concerned with 360 support at this point, you could just bypass the 360 board altogether and hook up the cthulhu directly. If it still doesn’t work after that, there’s an issue with the cthulhu.


#49

Update to the above -

Flashing from within the stick is coming from what I assume is where the 360 Pad/Stick LEDs are located normally, so it doesn’t appear to be anything troubleshooting related (At least to my knowledge). Even after downloading the Wired 360 Controller drivers for my PC and testing it on that stick displays as USB Device Unrecognized, holding down HOME before plugging the stick in also displays as USB Device Unrecognized.

To summarize -

Stick is by default in a “Xbox 360” state. Holding down HOME is supposed to switch it to “MC Cthulhu Ps3/Ps2” state
Windows 7 PC does not seem to recognize either state (Assuming they are even properly switching as they are meant to) as a valid USB device when plugged in, even after installing 360 Controller Drivers on the computer.
I no longer have a 360 to test it on, but while I still I did it worked fine on that.
Attempts to get the stick to work on my Ps3 have proven unsuccessful over the course of the few years I’ve owned the stick, though at once point on a Windows XP PC both the 360 Fightpad and MC Cthulhu states were read properly

I don’t have any current/self-taken pictures of the inner workings/wiring of my stick, so the best I can do is a photo taken by the creator after it was made just to show what the lay-out is - however I myself am not knowledgeable in regards to wiring. http://i.imgur.com/Q9kwxBW.jpg

I no longer care about multi-console/360 support, ideally I just want to be able to plug into my Ps3 and have a working Ps3 stick without having to abandon my stick case. Everything else can go if needed.


#50

Pics requested


#51

Flagging “WTF” when people try to help you won’t get you too far here. Open up the case and plug the Cthulhu directly into the PS3 using a a USB a to B cable (make sure to unplug the RJ45 cable from your ps3 or pc first, plug both in and things will be fried). If it works , you can simply replace the Rj45 jack with a USB jack, leaving the RJ45 cable disconnected.


#52

I’m not the one who flagged anything (Unless it was done as a misclick), will update with pics + the results of this when I have the opportunity.


#53

Eh, it happens easily on phones.


#54

Ok, figured I’d post pictures before I proceeded in taking anything apart and making a big mess

http://imgur.com/a/LUGyC

Based on what I’m seeing (In the first picture) the receiver where I’d normally place the other end of the USB A to B cable into is positioned to be facing part of the case itself with basically no room in-between, the only way to plug anything into is is going to be unscrewing the Cthulhu entirely before I can plug it in does this seem correct?


#55

You know that you’re supposed to hold down home WHILE you are plugging it in right? You mentioned holding it down before plugging it in, dunno if that was just a different choice of words.

Do you have a multimeter to test the wire connections? First thing I thought of was perhaps the Home buttons of the PCBs aren’t connected properly to the imp or to the button or the microswitch of the home button is going out so it’s not working. That doesn’t explain why it would show up as an “Unrecognized USB device” though.

Both of those PCBs should work fine with a PC. You’ll usually get an “Unrecognized USB device” if the D+ Green and D- White wires of the connection are mixed up. Considering you’re using an RJ45 to USB connection, it could mean that one or both of the signal (D+ and D-) wires on the network jack side weren’t crimped properly and isn’t transmitting when plugged into the jack

When you plug it in to any USB source does the LEDs for the 360 board light up?

Have you verified that the wires going into the screw terminals on the Cthulhu are all solid and aren’t coming out or loose?

Having a multimeter means you can check the ground is flowing thru both boards, that the voltage is powering both boards, that there is no signal loss from any of the 4 wires from USB (Ground Voltage D+ D-) from one point to another, you can check the RJ45 to USB cable is correctly crimped. etc etc etc. If you have a multimeter, you can literally continuity test every point from one step to another to narrow down the potential issues.

Also, whomever padhacked that fightpad/brawlpad shouldn’t be putting glue on top of his solder points, but glue on the wire next to the solder points, this allows someone not only to make corrections on the solder point if necessary without tearing the glue off and risking lifting a trace, but also prevents the wire from being lifted up.

I’m all for you potentially fixing your own issue here, but if you don’t have the tools to do anything about it, I’d just suggest taking it to another modder.


#56

Yeah, you’ll have to unscrew it. Put something non conductive between it and the imp board to prevent contact while you’ve got it loose.


#57

LEDs for the 360 board do light up upon plugging it into any USB source, they flash upon being plugged in and then stop or go out for lack of a better term. If they are supposed to be continuously lit after being plugged in then that is not the case.

And yes, I know that I’m supposed to hold down home while plugging it in.


#58

Are there buttons that’d match the color of the characters on the dualshock buttons? Or is that something I’d have to pull off with paint. Preferably Sanwa, but Seimitsu work as well.


#59

You can order buttons that are approximately the same colors. Or you could order buttons that allows you to put artwork under the cap and then you can make them actually look like bigger versions of the buttons on the dualshock controller. Paradise Arcade, Focus Attack and other shops allow you to purchase individual buttons.


#60

e: nevermind, question was answered in prior post on second look, and through a bit of research on my own part. Thank you so much for your help @Amerika!