AE PC input delay?


#1

I was reading some posts on Unity earlier. Someone mentioned that there is roughly 2 frames of input delay on the PC version and its caused by a glitch with v sync. I’ve tried using in game v sync and D3DOverrider which is basically v sync + triple buffering and no v sync entirely. I couldn’t really tell if there was a difference.

It does seem though that there is slightly more input delay than the vanilla PC version. I wen’t back and forth between both the games and vanilla seemed a little more responsive than AE.


#2

I really wouldn’t be surprised if there’s a v-sync bug in this game. For some reason, AE feels the same as playing on my console + TV, whereas vanilla felt like I was playing on the arcade machine.


#3

It’s weird. I’ve been playing vanilla for 2 years and my combos feel so off in AE…


#4

Are you sure it is a bug? After all, the very nature of v-sync is to introduce some latency between the image on the screen and the game-state.


#5

Considering that I am using the same settings between Vanilla and AE PC and it really feels like Vanilla isn’t as sluggish when I press buttons.
I went back and forth between the two versions at least 10 times with the same character and Vanilla felt superior response wise.


#6

33ms of latency is too much…


#7

You’re right, that is almost twice the theoretical maximum latency for v-sync at fixed 60 fps (16.67ms).


#8

If you’re using an nvidia card, make sure you have “Max Prerendered Frames” set to 0 as well.

But I do agree, AE PC in general feels laggier and less smooth than Vanilla.


#9

Is there a way to measure this more accurately? How do you guys measure input delay anyway?
Yes pre rendered frames are set to 0 on both versions. The settings are the exact same.


#10

If you really want to measure input lag properly you need to split a signal between an LCD and a CRT, as well has have the buttons trigger an LED. Delay between LED and CRT will give you base (system) input lag, delay between LCD and CRT will give you monitor lag.

Leave the LED out if you just want monitor lag. Leave the CRT out if you just want total lag.

On top of that you need something that will capture 60+ fps video, in order to get accurate measurements.


#11

Ok fuck that. The point is that there is delay and is there no way to fix it :frowning:


#12

I only noticed delay like this after that patch got released on GFWL.


#13

THAAAANKKK YOU.

I just checked for the first time, turns out I had pre-rendered set to 3. I feel like suddenly reacting to opponent moves has become much more doable.


#14

AE is definitely slower to register inputs than vanilla was. Feels like playing in syrup in comparison.


#15

Yeah definitely there feels to be some input lag. For example with Ryu the solar plexus strike -> cr.fierce link is very hard for me to perform even with plinking, while on PS3 or 360 I can do it no problem.


#16

Are we certain that these reported cases of input lag aren’t just people not perfoming the fix listed above?


#17

I’ve tried the fixes…feels the same =/


#18

Just deactivate VSync - the game is super smooth and has no notable input lag. You’ll get tearing occasionally, but rarely (or I just don’t recognize it anymore).


#19

Honestly, i felt the same input lag in training mode. just disable Vsync, and have your video card do the vsyncing. make sure filtering is also set to OFF not default. And if your menu’s are not laggy as hell, turn back ON RenderingThread in the config.ini

start hosting games and you’ll be guaranteed at least the games’ FPS setting is on FIXED.


#20

Agreed on the input delay, it was like treacle when I first started the game up. Compared to vanilla PC even the menus were sluggish.

I did all the above plus downgrading my nvidia drivers a few versions, which got rid of the random framerate dips (which I couldn’t perceive in fullscreen but could in windowed mode, it’d randomly drop from 60fps to 51fps very briefly every couple of seconds).