Akishop PS360 +: broken PSX and DC support, lack of support, mismanaged priorities


#1

Hey all, first post here.

Argg, I’m so frustrated! For the past year, (since the last firmware release) I’ve sent multiple emails to Akishop for the lack of reliable PSX and DC support, along with questions to whether they are going to eventually support more retro systems.

Their usual responses are:

“we are aware of the problems, priority now is PS4 and XBOne”.

“PSx will be updated so it works much better, we have not had any time yet. Try to force it into PSX mode when you insert the cable, see if that works also.”

“We are waiting on our software engineer to get better, once that is solved we will work on this again. Priority now is PS4 and Xbox One to try and solve it as easy as possible, but we are working on it. No timeline yet.”

“Saturn will be next, we will see after that what happens as we are busy with next gen at the moment.”

I’m no monster, and can understand when people get sick and schedules get pushed. But c’mon, it’s been over a year with these same problems!
Fixes to the current support should be top-priority!. That’s business 101.
Otherwise it’s false advertising.
But that’s the thing that bugs me the most. They boast that this works on PSX and DC, but it really doesn’t!

I’ve gone through all the hoops of trying all the different methods to try to get these working. I’ve used multiple RJ45 PSX cables, tried force-modes, verified all my connections, even tried the disconnect->connect methods for different boot screens on both PS1 and PS2 systems. To no avail.

It really seems they are not caring about their product other than making more money on new-gen support, rather than fixing what they officially state is supported.

Now I own 4 of these boards, because like many, I was a believer that this was going to be the ultimate controller PCB. I have 2 fight sticks that host the PS360+'s, and a 2-player JAMMA interface box for connecting my 360 to my Arcade cab. But now, I’m regretting going with the PS360+'s, and should have backed the MC Cthulu, or other (cheaper) PCB solutions.

I guess this is more of a rant post, but I really needed to vent about this, and SRK seems to be the place that PS360 info is most prevalent.
My patience is running thin, and I’m very close to just putting these boards up for sale and going with another solution.

Has anyone else had contact with Akishop lately, what are your experiences with them?


Absolute Question and Answer Thread v.3 (ASK YOUR QUESTIONS HERE!)
#2

I, my self never had any issues with PS360 +, and I use my PS360+ modded stick on the PS3, PS2, DC and Xbox 360.

The PS360+ primary support is the PS3 and Xbox 360, PS2/PS1 and Dreamcast was added later as an after though.
There is also ALOT of demand for XBOX One and PS4 support, it seems like the people wanting PS4 and XB1 support is the majority (or very vocal minority) compared to PS3 and DC fans.

Also I did notice the stick sometimes, only works if I boot the console first, then plug in the controller.
The MC Cthulhu is more reliable when it comes to retro consoles (although Turbo Graphic 16/PC Engine Support is spotty at best).

Also note the quality of your system cables and possibly the model of your console has a role to play.
Like I got a (SCPH-30001 a.k.a. revision version 4, 8 screw model) original series FAT model PS3 with the i-link/firewire port and connector for the network adapter/IDE port.

What version of the PS2 you have?

As for DC support I got nothing.


#3

That’s the thing, I’ve tried all the usual avenues mentioned on in this forum, and still can’t get my PS1 or PS2 to recognize the PS360+'s.

I’m connecting them to a PS2 Slim, and a PSOne (mini), and neither system recognizes the boards.

I’m an arcade cabinet guy, some people here might recognize my handle from some of the arcade forums, so I know my way around wiring/soldering/crimping and such. At first I crimped my own cables together, trying multiple types/quality of RJ45 cables (even set it all up to a terminal block so I can quickly swap out and test each stripped RJ45 cable). Couldn’t get it to work. I verified my connections via continuity tests from the board to the pins on the PSX connector too, so I know that’s not the problem.

Then I figured I’d try the cables from vendors, got mine from Jasen’s stock, and that didn’t work either.

I tried all the different boot-up techniques, having the systems both powered on and off when connecting, forcing PSX mode… still no luck.

And yeah, I got the latest firmware.

Don’t get me wrong, they work fine for PS3, PC and X360. And I realize PS3 and X360 support is the primary function, I mean that’s what got me hooked in the first place. But the secondary function of retro support is what made me decide to go with this board over the MC Cthulhu. To allow these supported functions to go unfixed for over a year, that’s just seems irresponsible to me.

If they can at least get PSX support to be reliable, then that would be good enough since there are a ton of adapters out there…


#4

Issue for me is I can’t replicate your problem with the boards.
Which makes it harder to help you trouble shoot.


#5

I own two PS360+ boards and the DC support on one of them isn’t working. It’s not the cable either, as I’ve tested with multiple cables on both boards. Haven’t tested PSX support yet but not looking forward to finding out that might be shot also. Sad to read that Akishop isn’t supporting their product very well. Felt the same way when I bought the original PS360 and ran into a ton of issues back then. Unless something changes with the vendor support, they aren’t getting any more of my money going forward.


#6

Hey man!

I don’t have the PSX cable for mine, so I can’t comment on that, but in the case of DC support, I started to think that either my PS360+ or my DC cable was at fault, but it seems that for the PS360+ to work with my DC, I have to turn the DC on, then plug the cable into my PS360+. This is awkward as hell, as I’ve heard stories about people frying the controller inputs on their DCs by doing exactly this.


#7

If they’ve been telling you that they are waiting for their software engineer to get better for this long of a period of time, perhaps it’s more than you know… a cold. If someone’s been out of the game for this long of a time, perhaps their legacy developer is deathly ill or something.

Nothing wrong with being frustrated, and I have noticed that PSx does need an improvement myself, but boiling it down to not caring or going for a cash grab is kind of obtuse. If you’re that frustrated, just sell the boards.

Have you offered them specifics, such as serial numbers and games that you are trying? I have a fat PS2, and it works fine on it with my limited game selection, but I know the protocol can be kind of vast depending on the games and systems.


#8

I remember once toodles said one bad code entry and your board that you tried to replicate as a PSX could become a “toaster” instead.


#9

Sorry if this is a silly question but are you getting the same results on all 4 boards that you own?


#10

That’s what i’m afraid of as well since I still use my DC a lot.


#11

Hey emph! Yeah that connection technique is what people are using on their PS2’s as well. It really is cumbersome to have to keep disconnecting and reconnecting the controller for it to recognize. This is definitely one of the things they should fix.

I really hope that’s not the case. That would be awful, and heartbreaking! Hopefully their engineer is only temporarily out of commission.

Yeah, if this next firmware update doesn’t provide any positive results, then I might have to do just that.

Yup, I’ve given them as much information as I can. Most of the games I’ve tried have been mentioned in other threads here, but it feels like my description and contact messages are going unheard or ignored, since a lot of their responses are “we know the problem. XBone and PS4 support is more important”.

No, that’s a great question.

I went ahead and tried out all my boards. 2 out of the 4 boards seem to recognize with intermittent functionality. Connected from a cold start, none of the boards work. But when I connected those 2 in question after boot-up, they seem to be recognized…BUT, sometimes it’s not recognized 100% of the time and button inputs are being missed when they are.

The only difference between connecting these 2 vs the others is that my RJ45 cables are connected directly to the RJ45 port connection on the board, rather than going through a Neutrix RJ45 panel mounting port first, then to the board.
I remember reading in the Hardware Overview pdf, that there is a nominal 200mV drop in voltage when using the RJ45 connection. I am wondering if the recognition and dropped-inputs issues pertain to the signals not being strong enough to pass through the interim panel mount, and through a 10 foot cable.

My next test is going to be connecting the RJ45 cables directly to the board using the RJ45 Alternate hook-ups.


#12

The need for plugging in the controller after the system is powered makes sense to me since it’s running an autodetection algorithm. They probably avoided looping the detection to allow for USB as the default or something. At a guess, if you held the forced system button while powering the system, the detection would work (in regard to that particular issue).

The 200mV drop, based on looking at the board myself is from the front end diode. Going to the alternate hook ups for the other RJ45 lines won’t do anything. If you want to bypass that little front end to check the voltage I’d put the VCC line straight to the screw terminal, which seems to avoid that protection. Maybe take a multimeter and read the VCC voltage when you DO use that RJ45 port entirely though and compare. It’s possible the voltage is being lowered too much. I just did that type of bypass when testing something with the crossbone, so I know that it’s correct.


#13

I know with games like the Metal Slug Anthology, Mega Man X Collection and other collections going from the game select menu to the actual game will cause the controllers to re-sync
This will blank out the PCB and the connection has to be reset. This is automatic in actual authentic PlayStation controllers, but in the PS360+, sometimes with the Cthulhu and even some unlicensed 3rd party PS2 pads will stop working.

The problem is only replicated and magnified on PS2 titles on PS3.


#14

Mhh my ps360+ also doesnt work on playstation anymore, it did work before but now it seems the pcb isnt recognizing the system at all. As i connect the pcb with the cable to the system the lights on the pcb flash just for a second, doesnt seem to get a proper connection. I already ordered another rj45 ps2 cable from focus attack, hope its just the cable. Could anyone confirm that its probably the cable, cause im just guessing.


#15

I had this exact problem on my DC. I reflowed the pins on the RJ45 connector and now it works better, but I have to insert the cable very gently into the connector to get a solid connection for some reason.


#16

@emphatic‌ Its not my intent to derail this thread but could you describe exactly how to reflow the pins, cause im not familiar with reflow soldering technique.


#17

Just heat up the solder and the pin to ensure there is a solid solder connection with your solder iron. I’m no expert, but that seemed to have done the trick in my case. The connector felt a bit loose before, and less so after.


#18

Pretty much you are re-melting solder. Usually reflowing applies to the whole board and not just a single componet or a component with ALOT of connections like a cpu that gets smd soldered to a board.

For a RJ45 connector its just heating up 8 pins, make sure each pin has a nice coating or wetting of solder, for though hole components you want solder on both sides. This is often helped along with flux. If avaliable I would use lead base solder has it works so much better than that RoSH lead-free garbage.


#19

If their software guy is sick, then they should be releasing the source code so other people can help move the project along. After all, it is open source and the code should be available since it’s released under open source licenses, so it should be available anyway. If it was OS I would be willing to bet people would have the retro stuff fixed easy. Especially people already familiar with those architectures, maybe some of the emulator programmers would help.

But without the source being available, that will never happen.


#20

My early experiences with soldering were all bad because of lead free solder. Made the switch, and things became 100x easier.