AMD/Nvidia chipset issue with Hori Real Arcade Pro V3


#1

Sure that this is NOT the first time a glitch has popped up with a mass-market joystick controller, but these should be noted and posted.

Most glitches are noted with the Mad Catz Tournament Edition joysticks – and those have generally been fixed with official MS XBox 360 drivers for PC’s running on INTEL chipsets – but I don’t know that as much has been written about the Hori side of things… especially about PS3 versions of Hori controllers.

A technical glitch popped up when I tried to use my 2010 HRAP V3 SA on a PC I inherited from my father. This PC runs Windows XP Professional, 2GB Memory, AMD Athlon 64x2 Dual-Core Processor with an NVidia GeForce 6150LE. Granted, it’s a not a beast machine by any stretch but it’ll do for what I use it for (gaming, basic video editing) as well as basic web-surfing.

Toodles’ MC Cthulu replacement PCB (in an Agetec case) navigates the PC retro-gaming/freeware fighter world easily without a sweat. The main software issue as far as Vanguard Princess was concerned was “ye olde Japanese/English language barrier” but I figured out what was going on after a few hours of first cursing at the PC when the .NET framework family of frustrating MS downloads wouldn’t install at first (most finicky installations of all software I’ve ever installed in a computer – gotta turn off all system protection or the software WON’T install!) and finding the joystick lever didn’t work one bit… The stick lever issue resolved itself after checking the “Joystick” box on the front window options for Vanguard Princess. (It’s always the undocumented stupid-easy stuff that kills you!)

Now on to the fun part with MAME!

The MCC Agetec worked fine with MAME… No issues.
Hori’s HRAP V3 SA – the buttons registered, but not the lever itself! Funny thing is that the PC’s Windows control panel actually shows the Hori HRAP V3 PCB as active. Windows recognizes the PCB as Hori Real Arcade Pro V3! The lever and buttons actually register WHEN you test/calibrate with Windows but the joystick lever itself doesn’t actually friggin’ work with MAME or Vanguard Princess!

The solution presented itself after tries with different programs that mapped controller inputs to the keyboard —
The only program I find actually reliably works without needing a FAQ or Japanese-to-English translation is X-padder. Stupidly easy to figure. (Take that D-Padder/DS3 and Joy2Stik. Those programs require courses in ancient Egyptian language to figure out in less than a day!) The only thing I actually had to reconfigure was the joystick lever itself. It has to be mapped to the directional buttons on the keyboard (Up, Down, Left, Right) to work with the games. The buttons on the joystick otherwise are functional. Only big advantage I see to using the HRAP V3 SA is the turbo in case you decide to play with side scrolling shooters. Very simple to go back into X-padder, Advanced Tabs, and check on the box for “Rapid-Fire” or “Turbo”. Then, you just adjust the tabs on the actual stick base itself for “Turbo” or “No-Turbo.”

Mapping the the joystick lever to the keyboard directional keys (with X-Padder) doesn’t really seem to change performance of the controller, period. The fighting games and shooters I tried all to seem respond the same as they did with the MCC Agetec… Ie, the games that had piss-poor control before still had piss-poor control after fixing the HRAP V3 software-interface issue! LOL


#2

So George I take it that you got your stick working on your PC now?

I do find this surprising as I also have AMD CPU and I have no issues. But my Motherboard chipset is AMD and the Video is ATI/AMD.
I do hear how a mix of AMD processors and Nvidia video will have some issues, especially older early XP/ late Win 98 era devices.
My best advice is to a mix the mix of Nvida and AMD.


#3

Usually, when the joystick doesn’t work, the game only accepts one input or the other (X/Y Axis or POV hat). Try switching the joystick to LS or DP.