Anyone else have this issue trying to update the firware for their Brook Super Converter?


#1

So I recently bought one of the Brook Super converters (PS3-PS4) to prep for SFV. Pulled it out of the box and it worked terrific, I was super happy with it, but then I noticed it was starting to time out after a certain period of time. So I looked on the Brook site for any fixes since I read they had firmware updates and awesomely enough the had already come out with a new fix. I downloaded every firmware update they had and then followed the steps in their instructions, but I mistakenly installed the older firmware B prior to the more up to date one A thinking that the older one had to be installed first. B installed fine, and then A also seemed to be going smoothly, until I had to exit the update mode with the 3 part code with the controller. I tried countless times, but I cannot get the LED on the USB to go back to the initial blue color that the instructions and video tutorials say it should go back to after installing firmware A. Instead it just stays a solid purple and asks me to update again. If I try updating it again, it blinks purple like it should, then turns red like its supposed to, but then it just goes back to solid purple again. After about two attempts of this it goes back to the update screen again. I’ve tried consulting Brook and other users but to no avail unfortunately. I’ve included a video of the issue that’s giving me trouble. If anyone has encountered this before and knows of any fixes or ways to reset to USB to its default state so I can install the firmware in the correct order (if that’s even the issue), then please let me know as I really like this device and would like to have it operational again as soon as possible.

https://www.youtube.com/watch?v=bveBXzR9vck


#2

One of Brook’s Engineers are active in tech talk and he offers some great advice.

He often checks the our Brook Converter thread


#3

I just bought and received the 360 to PS4 converter. When I try to download from the brook site using the PS4 internet, it says data not supported by PS4. How do I get the stick to work and eliminate the timeout?
My computer is an older Mac, so I don’t know if that is supported.
Zippy, etc, please let me know how to get the firmware updated…

I’m using the MCZ SFxT V.S. stick. It worked for 8 minutes and now I cannot get it to work again.
How do I get things updated?

EDIT: I guess I could goto a friend’s house that has a PC and update there.


#4

Your only options are to run Bootcamp or Parallels.