Arcade stick issue


#1

I have the 2012 Madcatz MLG TE stick.

My RT wasn’t working, and since my warranty expired, I opened it up.

The problem is the terminal that you connect the button to the PCB (I’m not 100 percent sure that’s what it’s called) is not working. I swapped wires for the buttons and the button would work then but not the one I changed it out too. I also tried swapping the PCB ports and the RT buttons would then work but the RB button (which I moved the wire too) would not.

The wires on the buttons are working. Just not the PCB port for RT.

So, my problem is don’t know if the problem is the PCB is bad for that specific port, or if it’s the cable that connects the PCB to the 360 controller chip.


#2

Can you take a picture? That may help identify the problem.

Is the terminal loose? It may have a bad connection to the PCB and require a solder fix.

Your troubleshooting up to this point was on point, so good job! I know a few people would throw their hands up and say “OMG! What do I do now?!” when their button quit working and would immediately ask for help instead of investigating. Welcome to Tech Talk, so far A+


#3

I think I fixed the problem.

I think the problem was the multi-wire that connects to the PCB and the 360 chip was not fitted perfectly. Once I pulled it off and put it back on to test, since I forgot to try that, it worked again. So, that might have been the issue all along. The button is working 100 percent of the time!

I appreciate the reply, but I’m fairly certain my issue is solved.