Arcade Stick Troubles


#1

Hey, guys I recently bought a MadCatz te1 stick used and after a couple of days the buttons and stick inputs would either not register or stick. What I was wondering was if it’s the PCB or the buttons and stick and how I would be able to tell? And if it’s the PCB could you point me to any that I can buy without having to solder. I’m completely new to fightsticks so I’m at a loss as to what to do. any Help is appreciated thanks


#2

hi

im assuming its a ps3 stick

the only solderless solution i can think of woud be a zero delay pcb, but you would have to sacrifice the select button to wire the home button in its place.

if you want to keep the select button, you can drill a small hole for a 12 to 16mm home button that you can pick up for peanuts.

if you do go for the zero delay, be sure to get the pack with the wiring for japanese butons


#3

sorry for not mentioning it, it’s a xbox 360 stick. would I still be able to keep the USB cable from the original stick and I don’t really need a home button


#4

The zero delay pcb is a ps3/pc only pcb. you can also get ps3/pc/ps2 versions, but there is no Xbox 360 version.

Do not buy it.

Best thing would be to put a WTB thread in the trading outlet for a TE 360 pen, you should be able to get one for around $20 to $30.

EDIT - My bad, before you do anything, make sure the slider is on dp

And then open the top panel, and check that all the qd’s are connected to the buttons,

Then maybe you need to grease the pivot on your lever, and remove your buttons, disassemble them, so that you take out the micro switches, then wash and dry the plunger and rim, just soak in soapy water and dry them

Retry, see if there’s any difference

You can also try swapping the buttons that work with the ones that don’t work, to eliminate whether it’s a pcb issue or just that the button microswitch has worn out and died.

These sticks have been out nearly 10 years, they microswithes may have gone through lifecycle of 1 million guaranteed activations.


#5

ok i’ll try that thanks the issue is that all the buttons do work but sometimes inputs are held or do not register at all and it’s the same with the stick also everything is connected


#6

no probz

try that, lets eliminate these things, then we can move on to more possible solutions

others will give you more ideas, i just know the basics

make sure you post back with an update, as it maybe useful for someone else in your position


#7

also try posting this in Tech Talk, they’ll probably know what to do


#8

hey sorry for not responding for a while I haven’t had much free time. I tried what you said but it didn’t help and so I decided to test something else. I plugged it into my xbox 360 and it seemed to never miss an input their while it seems to miss them when plugged into the usb port on my computer


#9

thats interesting,

what game is affected on your pc, have you tried with other games? have you got the latest drivers?
try using something like joytokey see if that helps

try using it on mame or fb and see if it has same issue

try using it in a different usb port on your pc?


#10

it was all my games that were affected and when I go to the device manager to check my inputs they do show up as sticking. i’ll try those other things though to see and get back to you


#11

so I tried plugging it into a different USB port and it seems to work but the only issue is that when I do a move like a forward punch the forward is registered 3 or 2 different times according to the input display in the game and it only happens when I press a button and do a movement at the same time. I don’t know if this is normal or not


#12

Either your front input panel is not wired properly or poorly causing data to come through bad or you need to update the drivers.
Try the USB ports that connect directly to the motherboard, then go into game controllers and see what the stick does.
After that get some software like driver manager and update all your drivers, you most likely have a lot out of date plus you will struggle to find madcatz, but many services keep repositories for use in their software. Try again after that. Honestly without looking at the stick I couldn’t really diagnose it