Big problem with my TE Fightstick- is it the board?


#1

I won’t pretend like I know all the specifics or part names since I’m not a tech guy at all, but I had my stick looked at yesterday and was told that the problem could be with the board. I’m asking on here too in case someone had a similar problem and knows what it could be.

My fightstick was working fine for a long time, but suddenly this weekend, the entire bottom row of buttons stopped working in mid-match. The top row worked fine, as did the stick and start/select buttons. I unplugged the stick and plugged it back in, rest the game and tried it again. I was able to use the X and circle buttons just fine on the ps3 Home menu, and on SSF4:AE when selecting a game mode. But when I was in an actual match, the buttons didn’t work. Yeah, I was able to select something with the button, but to do a kick…it did nothing.

The next day I tried it out, everything worked fine for the 10 minutes I played. I quit the game for a bit and popped in a movie with the stick still plugged in. A few minutes into the movie, it started rewinding. It wasn’t my Dual Shock, but it was the fightstick that was doing it, eventhough it wasn’t anywhere near me and nothing was on the buttons.

Yesterday I took it in to the game store I usually go to (Game Trader, a local shop that can do a lot of repairs to consoles and peripherals too) to see if a wire connecting to the buttons was loose or something. Nope. Everything looked fine. And here’s where my tech-less knowledge comes in- I forget if they said the problem was the board or the PCB…or if those are the same thing. They were wondering if the PCB for the TE stick was the same as the SE, which in that case, they could just do a swap. I emailed the guys about it so I could ask on here too and here’s what I got:

“I wasn’t able to get too involved with the pcb inspections, The housing and the turbo functions were covering most of the two pcbs… I was suggesting continuity testing but that takes more time. It seems to be a solution for intermittent problems, and yours is not so much intermittent as it is either or…I’m still thinking the PCB swap idea with an SE stick, or a pad hack.”

Sending the stick back to MadCatz is out of the question given how much the appearance has been modified on the outside, plus it’s been over 90 days since I’ve had it.Any help here would be appreciated.

Edit: Here’s what someone else emailed me:

“If you open up the stick, and look, there will be cables. The cable that attaches to the PS3 runs to a green piece of plastic - let’s call that the main PCB - from that main PCB, cables go to the joystick, and to another piece of plastic attached to a black block, which in turn is wired to the buttons. If you’re having a problem that’s affecting all the buttons at the same time, then it’s most likely that the problem is happening somewhere between that black block (where the buttons split out) and the cable which runs out to the PS3. One of the first things to do is to check the connections - like those between said black block and the main PCB - especially considering that loose connections are a common cause of intermittent problems. Also make sure there isn’t no glue on the left connector which is preventing it from being fully connected.If so Pull the connectors off the board. Remove the glue and stick them back into place. (IIRC they should be polarized, and have a different number of wires, so they’ll only fit one way.)It could be that the glue bridge is pulling out one of the connectors which is why it’s not responding well.”


#2

Bump. Anyone?


#3

Take pics of the insides.


#4

Any area in particular?