Bricked psp help


#1

hey guys, a friend of mine bought a psp on craigslist that the previous owner claims is bricked. here’s the description from the original ad:

I made a pandora’s battery and a magic memory card in hopes of unbricking it but it is not working so I’m wondering if the psp is actually bricked or if it’s a hardware problem. I recorded a vid me trying to unbrick it. As you can see in the video I first put in the magic memory stick, then the pandora battery while holding up which should trigger the psp to boot to the service menu. if you can’t tell what’s going on it’s in the video description:

I did test the battery and memory card in my psp and it worked perfectly. If anybody that is familiar with psps can figure out if it’s actually bricked, or if it’s a hardwear problem and how I could fix the problem I would greatly appreciate it. Thanks!


#2

I used to know a lot about the psp but I stopped rite before the pandora hacks but all my info i got was from here http://pspupdates.qj.net/ you probably know this site but if not i hope it helps. It is a psp fat not a slim correct and some batteries you can’t put pandora on at least that’s what I read. Also I noticed it said it already had the CFW on it and most of those have a recovery mode sometimes you have to hold like the R button while you turn it on or something like that I’ll try to look at some old files I have on my cp at home.


#3

You might have a dead LCD, or you might not actually be booting into service mode.

When you say it worked on your other PSP, do you mean that the battery powered up your unit, or that it actually booted it into service mode.

The last version of Pandora I used boots the PSP directly into service mode, no need to hold any buttons. I’m using an older generation phat battery, but it works on phats and slims alike.

I fixed a PSP for a guy today that was pretty similar, when he first brought it to me, the LCD wouldn’t light up, then when it did, I saw that it had been cracked several times. He replaced the LCD, then I used pandora and fixed the firmware no problem.

BTW, I watched a bit of your video, and I see a few things that might cause issues.

  1. Have your magic stick in the PSP BEFORE you power it on.
  2. Do NOT have the AC power cord plugged into the PSP during the firmware flash.
  3. You should NOT have the battery inserted before the mem stick. Unless Pandoras have changed drastically in the last few months, you insert them into your PSP and they instantly power on the PSP and boot it directly into service mode, so not having your mem stick in place and having power from the AC cord can mess this up.

Hope some of this helps.