Broken Hori stick?


#1

Hello, I got myself a Soul Calibur V Arcade Stick from Hori. How does this device work? It’s connected to my PS3 with the USB cable but pressing any button doesn’t do a thing. Do I need to install it first? (howto?) The manual doesn’t really explain this. How can I see that the stick is ‘on’?

Can’t be that hard… I’ve never had any problems with hardware before. What am I doing wrong? Or is it probably just broken :(?


#2

I have the same stick just for Xbox and got mine from MadCatz site. Today I went to play and the Xbox logo was fully lit up and the stick was none responsive. I tried both ports, different Xboxs and even PC all same outcome. It is set on DP and I even tried every other possible setting.

I imagine this is the same if not very similar issue you are having where it show its on but its none responsive. I have had the stick for about 2 months now as well and never an issue until today.

Would be awesome if anyone knew whats up.


#3

Really stupid questions:

  1. Is your “Soul Calibur V Arcade Stick from Hori” a PS3 or Xbox 360 stick?
  2. Did you make sure your USB cable is seated all the way in?
  3. What did your Indicator lights do?

No, the stick is plug and play.

  1. Did you have any LED indicator Lights?
  2. Is the top right corner of your PS3 screen showing a controller connected?
  3. Did you go into your settings of your PS3 Menu and manually change the stick to be Player 1 or Player 2?
  4. Is there any other controllers in use?

#4

Here’s a dumb question. Are you attempting to power the PS3 on with it?


#5
  1. It is 100% the PS3 stick.

  2. Yes, cable was seated all the way in. Plus both USB ports on my PS3 work fine, I tried with my headset and there are no problems.

  3. No lights on the stick are glowing.

  4. As above, no lights.

  5. Starting up my PS3 with the stick connected, It shows a message “Press PS Button”. So this means no controllers are connected. Pressing the PS button on the stick doesn’t do a thing.

  6. The settings don’t show the stick.

  7. Starting PS3 with main power switch, there are no controllers. Starting PS3 with DS3 PS button it says 1 controller is in use.

No, I manually turn on my PS3 console.


#6

I think your USB cord might have a break in it.


#7

Okay, that’s too bad :(. I’ll probably just buy another one then.
Thanks for the help.


#8
  1. He’s talking about the Hori SCV stick, not the MadCatz SCV stick.
  2. Your stick is probably defective. Call MadCatz support.

#9

Well I’m in luck. Amazon will send me a new stick, free of charge. Thumbs up for them!