Brook Converters Thread


#3021

Does your current PS4+audio board work in a computer? Have you tried forcing PS3/4 mode with Square/1P or Triangle/2P? if it’s a second revision it should use a proper USB A-B Cable so there should be data flowing as those cables are not used for charging smartphones and stuff.


#3022

@Torta Yes it works fine on PC and the consoles it’s meant for. Yes I did press those buttons when plugging it in and it still didn’t work. Do you have experience with this setup? Did it work for you?


#3023

The most recent update of the PS3/PS4 to Switch firmware says “Support wireless control for PS3/PS4 controller. Free of registration. Plug the controller to the converter with a cable for recognization first, and then the controller can be played wirelessly.” When I plug the DS4 in to the converter it works fine and then I unplug it and it does not work wirelessly. Is there a step I’m missing to get this to work?


#3024

@Torta @“GOGO.Zippy” I finally got it to work. I had to connect it to my PC in Xinput mode and plug in the controller while holding down the 1P key to put it in PS3 mode. Ever since I did that it worked on PC through the device and now it’s working on PS2 as well when I hold the 1P key when plugging it in. I tried 1P before but it wasn’t working until I did it on PC for some odd reason. Hope this info helps someone else out!


#3025

@warhead
Please use the latest file on Brook Website.
After updated file, Turned on Pro controller wired mode in system page
To connect converter with you PS3/4 controller via USB cable then plugged into USB on Switch.
Remove USB cable from converter and press down PS button on controller to link with converter in wireless mode.


#3026

Hoping someone can help here, I’m having problems with my stick on Windows at the moment. If I click gamepad controller, it shows button 13 as constantly on:

https://i.imgur.com/Wx9HK7y.jpg

This is causing issues in fightcade, as it won’t let me map any button until the button has stopped being pressed. However, no button on my stick corresponds to button 13. I’m unable to actually open up my stick at one of the screws is stripped, so I was wondering if anyone knew a way to disable a button through Windows 10?

I just plugged in my second stick and it has the same problem, so I guess it is a problem with my Brooks converter.


#3027

@Chocobuny
Which converter do you use on PC?


#3028

Hmm that seems to have worked! Thank you!


#3029

The white PS3 to PS4 converter


#3030

@Chocobuny
We tested white converter (PS3 to PS4) on WinXP/Win8/Win10. The button 13 doesn’t press down automatically.
Please check again w/o connecting your stick.

Was the B13 press down ?

If yes, please updated the latest file including compatibly controller icon on APP.


#3031

Yes, even without the stick the button is pressed down. I am currently running the latest update (v.2.2) from your website and it still has this issue.


#3032

Sounds like your converter is jacked dude. You probably just need to buy a new one. www.arcadeshock.com


#3033

Yo, so does using the Brooks for my Q4 offer less input lag than using legacy input mode on PS4? Just wondering, I’ve been out of the loop on here for a while.


#3034

Brooks has very low input lag. They are very good. You should cop one.


#3035

I reapplied the update. It works!


#3036

So just a quick question on the PS2 <> PS3/4, or Xbox converters…

Do the adapters allow opposing directions to be pressed simultaneously? Like Up+Down, or Left+Right? I’m on the hunt for an adapter that might do well with DDR pads, which require many combinations of directions be pressed at the same time.


#3037

PS2 to PS3/4 converters work OK w/my Project DIVA gamez & Miku Hori controllers- they have combos of buttons you have to press at the same time.


#3038

I just received the Brook X Adapter for Ps4/Switch and I wouldn’t recommend anyone getting it.
After using the latest update(because it wasn’t working with Switch). I attempted to do Menu + X, which seems to have bricked the adapter. The light just stays on and it can no longer change modes. The reset button also doesn’t do anything. Seems to be a waste of $54 dollars. I use their UFB, but their X Adapter wasn’t tested.


#3039

Please set in SWITCH mode to connect with your switch.
Refer to the document file for set mode on X One Adapter.


#3040

Yes I know Switch mode is Menu + B, but that wasn’t working so I attempted another mode (Menu + X/Xbox mode). But after I switched to that mode my adapter has become “stuck” in Xbox mode or bricked. For example the charging indicator no longer turns on, and trying to change to any other mode no longer works.