Brook Converters Thread


#3061

I was having some issues trying to update my firmware on my UFB. Works perfectly when I connect to my PC and shows as a Xbox 360 controller. All the inputs work fine in games so I know all the cables are correct. Whenever I try to connect my stick while pressing the PS/Share button with the updater open nothing happens. It makes the sound like it connects then disconnects and then is recognized as a normal 360 controller without the start button appearing in the updater.

Windows 10
TE2 Stick

Any suggestions?


#3062

Will you make a Wii U Pro to Switch adapter or is the feature already inside the firmware of some of your adapters?


#3063

Not sure its the right place to ask but thought i would ask. I took a FGwidget and wired it to a PS3/PS4 Brooks board so i can use my Sega Saturn 2 pad to play SFV and other fight games. When i first wired it and updated the firmware some years back it worked perfect no lag, all buttons worked not a problems what so ever. But i had to take a break from playing games due to real life issues. Now that things are calming down, I wanted to play again so first thing that came to my mind was to update the firmware on my brooks board. Update went fine. So i fired up SFV and noticed 1 button was not working. Tested in windows devices manager and sure enough 1 button was not working. Thought it was the pad so i went and got another, same thing. Got a 3rd pad. Samething. Tested the connections on both boards. All get connection and no shorts. Only thing i can think of is maybe the latest firmware update may have caused this. Is that possible? I know the brooks board were never meant / made to work the way i have it connected with a FGwidget but it worked perfectly fine year or so back and now 1 button doesnt work. Any thoughts suggestions? Is older firmware out there i can try to least confirm if its a firmware or something else?

Never Mind: i figured it out, i had to remap the buttons on the pad due to FGwidget sometimes needing that done. all fixed now, sorry about that


#3064

Hello Brook Team, @“GOGO.Zippy”

I am using the PS3 to PS4/PC white converter, with Madcatz TE PS3 on PC

after the Street Fighter 5 Arcade Edition update today, the converter is not responding to any of the JoyStick movements or axis.

All buttons are working, just no movement with joystick direction UP, Down, Left, Right.

Any possible fixes or tips are welcomed thanks.


#3065

@Slcikx
Please set in DP mode on the your stick to try


#3066

@GOGO.Zippy - I’ve just received my Brook X One Adapter and would like to also test the beta file which modifies the XB1 to PS4 touch key ?

Thanks in advance !! :slight_smile:


#3067

@“GOGO.Zippy” - I’ve been using my Brook X One Adapter for couple of days now and am loving it, ironically I did have some problems getting my Xbox Elite Controller working on Xbox One X. :o

Following the supplied instructions the controller refused to connect, however after alot of trial and error I finally established an initial connection by not fully inserting the X Adapter, the problem seems to be its pressing against the sync button ?

Also when the console is off, my testing has shown this method is the only one that works for me to get everything working on Xbox One X :-

Hold down the X button, then press the Brook Button and the console turns on in a couple of seconds, you can then release the X button… :slight_smile:

Getting it to connect with PS4 Pro was very easy and it works flawlessly !! ( As above thou using the Brook Key to replicate the Touch Pad is very awkward )

Like all the other Brook products I have the X Adapter is very well made and although its slightly fiddly to install and remove, it intergrates very nicely with the controller. ( There is zero lag aswell ). =)


#3068

@GOGO.Zippy
I’m one of the Kickstarter backers for the Xbox One adapter, and it’s a really great product - congratulations :slight_smile:
Would it be possible for you to provide me with the beta firmware that changes View=Touchpad, please? I use MacOS, so hopefully you have a suitable version?


#3069

Hi, I’m looking forward to buying a brook super converter (xbox 360 -> ps4) for Madcatz Street Fighter IV Tournament Edition Fightstick (round 2) but I might aswell ask first, if anyone knows if it actually works / if it’s compatible?


#3070

It works.


#3071

@“GOGO.Zippy” - Thanks for sending me the Brook X One Adapter Beta V1.25 file firmware.

The View/Touchpad PS4 change works perfectly and I also noticed the Xbox One X syncs faster with this beta firmware. ( Even thou it was perfectly fine before )

Something else not mentioned in the manual is when switching from PS4 to Xbox the Brook Key flashes Blue/Red and only blue when switching back to PS4. ( A nice touch indeed ) … :smiley:

Anyways its a very nice product which has exceeded my expectations !! :slight_smile:


#3072

@Komaklub
Thanks your reply and use Brook converter
Here is New manual


#3073

@GOGO.Zippy

So I have been scouring the internet for a few days. I need some help. I’m trying to connect my Switch undocked to my PS3 MadCatz TES stick. I plugged a OTG cable from switch to PS3/switch adapter and then plug my arcade stick in to the adapter. It will not work. The adapter blinks green. I can get the PS3/DS4 to work in this setup but not the arcade stick. The controllers show a solid green VS flashing green when connected to the arcade stick.

Has anyone connected a MadCatz ps3 stick to an undocked switch? Please help. :slight_smile: thank you.


#3074

@"MGL Somatic"
Please use the latest file to update.
www.brookaccessory.com/download/Switch/

Don’t register with Switch in Bluetooth mode.
Set Pro controller wired communication mode --> ON
http://www.brookaccessory.com/detail/10323791/


#3075

@“GOGO.Zippy”

Thanks. I’m on the newest firmware and have already turned wired communication on. My ps3 controller connects but not my arcade stick. My arcade stick does light up and is fully functional but not working. This is in undocked mode using an OTG cable.

Maybe I have a faulty converter or do you think syncing the ps3 controller first messed it up?

Is it possible to connect the arcade stick directly to the switch undocked? Have you seen this done? Thanks.


#3076

@"MGL Somatic"
Please test converter and arcade stick on PC.
Do they work in the game control panel?


#3077

@“GOGO.Zippy”
@Brook_Engineer

I appreciate the help. So I connect the arcade stick to the pc using the adapter. It connects under “Wii U converter” with a solid green light. When I go to calibrate it does not acknowledge any button presses or joystick movement.

I tried the stick on my PS3 and it indeed works. Also, when plugged in to the switch the arcade sticks control panel lights up red when the corresponding buttons are pressed. I’m pretty sure the arcade stick is fine.

Wondering if I have a faulty Converter? I can easily replace it using Amazon so that’s not an issue.

Do you know if it is possible to connect the MadCatz arcade stick directly to the switch undocked using an OTG cable?


#3078

@“GOGO.Zippy”

I’m buying 2 more adapters through Amazon to test them out. Hopefully I can get the arcade stick to work with the switch using an OTG cable undocked. I’ll let you know my progress. Thanks.


#3079

Hello Guys, Mine Xbox to PS4 converter (purple one) today started disconnecting after 10 minutes and then it reconnects.

What is it the problem? I have the lastest firmware on the ps4

EDIT: I forgot to say that I have the lastest firmware also on the Converter (2.2.6 - 2017/10)

@“GOGO.Zippy”


#3080

@“MGL Somatic” I think those Early Mad Catz PS3 sticks are a bit touchy with the Brook Converter, as they are already touchy if you dare use them on a computer. Since you have a TE, you should try to get a Brook PCB.