Brook Converters Thread

I just recently got the Switch adaptor and when updating the FW I saw the same error and figured out that I needed to have a controller plugged in. I used a DS4.

Also I tested one of my Cthulhu boards last night and it worked on the Switch adaptor. I did need to make sure that Pro wired mode was enabled on the Switch.

The Pro wired mode is on, as it works for my Xbox controllers (360 and One), but I can’t seem to get my stick to work properly. I suspect I’m not pressing the correct buttons correctly to pair it correctly, since I’m not sure which buttons counts as L1/LB, but I’ve tried the obvious ones unsuccesfully. Did you do anything special to get it working?

I didn’t need to press any buttons while plugging in, but I did have to first initialize using another controller (i.e. Joycons, or Pro), then go to Controller settings -> Change grip options. Once there press A several times until the your stick shows up as a Pro. This is what I’ve had to do with all devices being plugged into the brook adapter though.

Thanks for your response. Sadly, it still doesn’t work for me, maybe because it’s the Xbox version instead of the Playstation one, even if it’s on the compatible controllers list. I’ll see what tech support has to say, and maybe I’ll try to get a refund for it and switch to the PS model.

Oh didn’t realize you had the Xbox version. I have the PS version, so the adapter recognizes the PS3 mode. The Cthulhu has support for the original Xbox, but not 360 or Xbox One. Not sure if that’s where the confusion may be.

I got an email from tech support, and they’ve actually helped with the VIDPID error. Turning off Steam actually made it possible to update the firmware, so hopefully that helps out a few people.

Sadly, my stick still doesn’t work. I’ll try to return it and swap it for a PS model.

So I got the PS version, and the Toodles works great.

In case any one is wondering, Logitech controllers don’t seem to work with either converter. I’ve tested the Dual Action and the F310 in both Direct Input and XInput modes, and nothing worked.

Is the Yellow ps3/ps4 to ps3/ps4 the “correct” one to use ds4 on pc? Also, is it better than sony wireless adaptor?

That adapter is used for a Ps3 stick on Ps4 or a Ps4 stick on Ps3. Not really meant for PC. Your best luck is the Wireless Sony adapter, as that is an official product made for that purpose.

Hi dudes,

Feel like I’m going out of my mind but am convinced I’m doing something wrong.

I have the red PS4 to XBONE adapter and I’m trying to update. But when I plug it in and try to go to ‘update mode’ it does nothing.

Do you have to use a wired controller for this to work? Or am I just doing something wrong?

@GOGO.Zippy I was curious, could there be an additional button layout added to the Brook PS3/4 to Neo Geo adapter for a Samurai Shodown-friendly layout? Something that would produce
BCD
A
On an arcade stick, where X is A, square is B, triangle is C, and D is both R1 and O? I don’t know if the latest firmware update allows any kind of button remapping, but when we were trying to run Samurai Shodown at a recent event none of the built-in layouts are particularly suited to it.

This converter allows you to do a button remap function, please look at http://www.brookaccessory.com/library/dl_file.php?dir=download&filename=tcat5w14sJy7fWisuBSLZjcbfYWJ4A&o_file=P3P4toNEOGEO_UserGuide_20161205V1.pdf

I am in serious need of help, just got my converter and really close to just sending it back, not understanding whats going on. I downloaded the update and tried to update, I get to where I need to do the button sequence on the PS4 controller, I do that on the controller and the next option is to “plug in controller” ?! It’s already plugged into the converter thats how I was able to get to this next screen, whats going on?

Hi, I downloaded the April 2019 firmware for the PS3/4 to Neo Geo adapters and they no longer detect my HRAP4 Kai in PS4 mode, or other folks’ PS4 sticks. Could you put out a fix?

My PS3/PS4 to Switch converter didn’t work when I got it, so I tried to update the firmware. When I tried to do this on my mac, the update app gave me a “network error” every time I clicked start. I then tried updating it on PC, and get a “Error: network timed out” notification, and then when I click “start” on the update, I get a “Notice: LDrom detected” pop up. When I click “okay” on this, the update fails. My converter now no longer lights up when connected to a USB port, and still doesn’t work on my Switch. I’ve tried running the firmware update app on two different PC’s, my iMac, and Macbook. I get the same issues (network error on mac and longer errors on PC) on all hardware. I can’t find anything online about this. I’ve tried disabling my antivirus and firewall on PC, and that was all I could think to do. Has anyone else had this problem? The converter seems bricked until I can successfully get the firmware to update.

Looks like the ps2 to ps3/4/pc adapter does not work with the Playstation Classic running retroarch.

It’s not going to.
The PS Classic isn’t designed to take normal PC controllers.
PS1 Classic is using it’s own USB Protocol.

It has nothing to do with Retroarch, and it has whats already installed on the PS1 hardware.

I mean other ps1/ps2 to ps3/pc adapters work on it just fine, and with retroarch I can then configure them to be standard, or dual shock, or flight stick, etc.

8bitdo controllers, the M30 and SN30 Pro work on the PS4 by using the Brook Xbox 360/Xbox One to PS4 adapter. All the buttons work.

M30:

X= Square

Y= Triangle

Z= L1

A= X

B= O

C= R1

L= L2

R= R2

The home button also works.

1 Like

Is there a way to use the PS4/3 to PS2 converter in a mode that auto-cleans an SOCD on Dpad, as well as prevents sending analog stick directions and dpad directions at the same time to send left on dpad and right on analog stick and vice versa? In some games this allows you to block on both sides, which is a problem.

Since most players just play on converter rather than bringing PS2 controllers I figured if the converter has such a mode that would largely solve that problem.