Brook PS3/PS4 "Fightboard" PCB Thread

I am having an issue getting the joystick to work. I have a Sanwa JLF with the correct orientation and do not get a response in windows of the playstation.
it is already updated to the latest firmware.

I have https://www.focusattack.com/ist-pre-installed-brook-ps3-ps4-fight-board-pcb-kit/

Any help would be appreciated.

Do any of the buttons work?

If they dont, you might need to update your drivers for xbox360 / xboxone

If they do and your joystick doesnt, you might need to check http://s730.photobucket.com/user/rtdzign/media/Misc/JoystickWiringGuide.jpg.html

For comparison, UFB

How to read the results.
https://www.youtube.com/watch?v=Li8sdHDWapY

I’m trying to use my brook PS3/4/PC pcb on a Rasp Pi with recalbox, but many buttons are not recognised (R1, R2, L1, L2, select, start)

Everything works fine on the pc, I think it is because recalbox doesn’t like ps4 controllers.

Recalbox sees the device as "Zeroplus PS4’, is there anyway I make the pcb act as a PS3 controller, or even PC, but not PS4 ?

Sorry if this has already been asked, I’ve only seen the question for universal fighting board

Just curious. Does anyone know or has tested the brooks universal fight board and the regular ps3/ps4 small board. Which one has less lag?

Go to the Lag thread and talk to noodalls. He been doing alot of lag testing.

The answer to your question is literally 2 posts above yours.

you may try

Manual Mode:
step 1 : Press button:
1P for PS3
2P for PS4
3P for Xbox 360
4P for Xbox One
1K for Wii U - Pokken Tournament
2K for Original Xbox

step 2 : While Pressing, connect fightstick to PC

Could an original DS4 touchpad be used with this board?

Very very happy with the ps3/ps4 fightboard. Works exactly how I wanted it to on PC (auto shows up as an xinput device).

Having touch pad input = select when using it on pc and ps3 is the best which makes it so I don’t even have to wire the “share” input.

My Hrap3 sa is ready to roll. Thanks Brook.

I just got two Brook fight boards in the mail. Brook w/ Audio and the regular Brook PS3/PS4 fighting board. I’m wondering, do I use the same update files for both? I assume they both need to be updated to the latest firmware since I just got them, but I’m having trouble finding info on updating the Brook w/ Audio.

http://www.brookaccessory.com/download/PS4/

Updated firmware only for PS3PS4 fighting board from what I can see here. I haven’t seen a firmware for the PS4+ audio fighting board.

@trillmaher
Brook PS4 fighting Board w/ Audio…
Never to update any file while getting

It can work well on PS4…

I don’t have to update the Brook w/ Audio?

you’d want to wire the share button if you want to update your pcb for ps4 firmware updates D:

Hi all, Ive just finished wiring with the Focus Attack ps3/4 board breakout board. Having a lot of issues getting pc to recognise. When i first set it up it I managed to update with brook updater from their site, all went fine and worked for maybe 3-4 matches then nothing it cut off. Now its not recognised and brings error ‘device descriptor request failed’. Ive tried all fixes from this webpage - http://troubleshooter.xyz/fix-usb-device-not-recognized-device-descriptor-request-failed/ as has seen that solve issues on here and elsewhere but no luck at all :frowning: Anyone can offer advice please? Pics of wires below. Thanks in advance :slight_smile:
https://image.ibb.co/k7QmwF/ss.jpg
https://image.ibb.co/iRFKGF/ssc.jpg

Hi I recenly bought a PS4+ Audio Fighting Board for a HitBox style stick and was wondering how to activate the SOCD cleaner. I had bought it because I have no soldering experience and was wondering if there was a solderless way of activating it. It says somethign about the J15 to activate SOCD but I’m not sure what that means exactly.
Thanks in advance.

@Afro I wonder if that was what the extra jumper in the bag with the breakout board was for. Try placing it over J15 to see if it works.

Thanks for the tip and the quick reply. This seems to work because default button assignement changes when I press a button and wire the stick.

But :

  • neither the pc or raspberry wants to recognise 4P/4K. And if I wire the stick with 1P or 3P, It messes up with Start/select, and 3K works only while going as Xbox360.

http://image.noelshack.com/fichiers/2017/14/1491217825-boutons.png

This is to say that I don’t think it’s a wiring problem. Anyway I have a pre-installed PCB, I followed this picture si I’m not sure what could have gone wrong.

Also no matter what I input at startup, games recognise my stick as XboX, show me Xbox and not playstation buttons so It’s certainly a driver problem. I’v updated the firmware but I’m not sure about what to do next. Saddly I don’t have a playstation to try it on, only my pc.

Sorry if this is all a bit confused, it’s pretty hard for me to explain this in english.

Is there anyway to wire it up so I could use the headset jack on a 360 madcatz TE with the PS4 audio board?