Brook UFB only fuctions when holding 'Home" button down before plugging in USB


#1

I just finished dual modding my R1 TE with a TE Kitty + UFB + Imp v2. I was testing the mod via game controllers in Win X and everything fired up just fine. Every button, every direction, every everything. I did have some difficulty getting the UFB to switch over to the Kitty pcb; this is where the issues soon began.

I couldn’t get it switch over using the designated “Home/Guide” button of the TE. I tried a few times of holding down the Home button before plugging in the usb cable, but every time without fail, game controllers would display an XBox One controller. I decided to try using the Neutrik rj45 mount and soon found success. Twice after attempting to hold down the Home button before inserting the USB, it displayed as "TE Kitty’ via game controllers. After learning that it didn’t continue to remain in TE Kitty mode after unplugging and replugging, I attempted to hold the Home button again to force it into TE Kitty mode… and soon thereafter EVERY led on the TE’s control module lit up as well as the UFB blue led.

The only way I can get the joystick to NOT have all leds is to unplug, and replug whilst holding down the 'Home/Guide" button. It then displays as an Xbox One controller again, and functions normally. If I unplug and replug, without holding the Home button? It still displays as Xbox One peripheral, but when you enter properties inside game controllers, it just looks like someone is mashing every button simultaneously and repeatedly. I can’t even force the UFB into specific modes, and I absolutely could before it began this.

I’ve since tested on ps3 and it’s similar behavior. If I plug it in as is, every led is lit; no response from joystick. Just as well the xmb will display “An unknown USB has been connected”. Now if I plug it in, again holding the Home button down before doing so, it functions normally & properly. So I’m guessing it auto-detected PS3 mode via the UFB. If it were still remaining in Xbone mode, it wouldn’t operate of course.

I guess I should mention that the Home button is the button dedicated as the “Switch” via Imp v2. It worked… until it didn’t. And now I’m left with this problem. Any advice?