Brook Universal Fighting Board Thread


#2674

Hi Bros
Brook fighting board is working well on V4.73 without updating file.


#2675

Well I’ve tried everything I can think of to update my board. Using Windows 10 it says Success, yet still timing out on PS4. It works just fine other than that. When I plug it into the PC I can force every mode even. Blue light no issues. Update with the small USB A to B cable.
Does anyone know how to actually check what version of the firmware is on the thing ? If it’s on PC in PS3 and PS4 mode it’ll say something like controller V 1.6 is that possibly the firmware number ? Sorry for the long post this is just perplexing me


#2676

how long does it disconnect?


#2677

It might be a crazy pipedream - but if there was some kind of expansion board made available for the UFB that would allow Switch wireless connectivity - man, I’d start throwing money at Brook.


#2678

Once the 8 minutes hit it just stops responding until I pull the USB out and put it back in, hit the ps button and sign back in. The blue light stays on it just stops responding to any button inputs


#2679

ykd, when doing an update to my UFB, I didn’t use a small USB cable or anything just the regular cable I use to plug my stick into the PS4.
Hold PS + Share as you connect it to your PC and it should all be good.

I’m sure you’ve already done this but I just wanted to make sure.


#2680

Now it won’t respond in the computer it loads up but device says “Unknown USB Device Device descriptor request failed”. And I haven’t done anything to it since last night when I messaged here.


#2681

Yup tried that. Might be a dumb question, but do you keep holding the buttons or let them go once you get the start button initialized?


#2682

You only have to have the buttons pressed when you insert the cable, then release at your leisure.
The stick will be recognized by the update software at this point and the firmware update can start when you click on start.

Have you checked that you definitely have the latest revision from Brook’s site? Just trying to rule out any errors.


#2683

Indeed I have 2.0, it says 2.0 on the Brook Downloader app. Would you happen to know how someone can check what is on the PCB ? It says it’s successful, and everything works fine, on PS3 no prob but the PS4 still times out at 8 minutes. So it’s like it’s updating, but not taking it? I’m running out of ideas here. My other Brook PCBs never give me this problem. But I’m kinda dumb to know how to check what’s on the PCB.


#2684

I did a time lapse, tutorial type thingie.

https://www.youtube.com/watch?v=gtCBnjRyEj4

Feel free to give me feedback if I’m wrong or there is a better way to do X or Y


#2685

Some people consider it a forgone conclusion that you’ll inevitably need to pause video during these kinds of tutorials, but seldom do I see it advised before the fun starts. Good work.

I have two suggestions for the future.

  1. Get yourself a good mic. It will be worth it.
  2. You can reduce over-exposure w/ color correction in either Final Cut Pro or Premiere.

#2686

I recently put in a universal fighting board on my custom stick. And I started to notice that there’s a delay on the stick input. Whenever I move the stick forward or back, there’s a like a stored input or that a dash comes out if I tap it once. I wasn’t sure if it was a stick problem itself or if it’s a pcb problem. Just trying to limit what the problem can be.


#2687

you may try to do firmware update


#2688

Just thought I’d post in here as well. Been having problems with my madcatz TE2+ ezy mod Brooks UFB.

Getting “unknown device” on win 7, when connecting to PC.

Registers fine when connected with start & select held down.

Blinking “LED3” light on the EZMOD TE2+ Board.

Modded with brooks UFB, Updated safely to 2.0

Won’t register at all on ps4 either.

Anyone else experienced this issue?


#2689

How are you connecting to PC? Using the regular wire or connecting to the USB port inside your stick?


#2690

The original te2+ wires screwed in to the EZMOD board, had the EZMOD UFB for a year.


#2691

What kind of solder should I use for touch pad function?


#2692

Standard electrical solder, rosin flux core
lead base if its allowed in your area if not don’t worry


#2693

say for example you mess up the wires on the TE2+ wires that are connected to the PCB, is there anyway to salvage that? those wires are so fine and tiny, i can’t ever get a good clean strip job, just taking preventative maintenance like anyway to get that 5 pin connector?