Brook Universal Fighting Board Thread


#2961

Got pics?


#2962

Here is what I did.

Basically I used 2 of the 5 wires that comes from the front panel.

If your cable looks different look at this image, specifically the 5 pins on the left. The 2nd and 3rd (starting from the top) are the two that you want. The 2nd is for the home button and the 3rd is the ground for it. I don’t remember if the lock continues to function but the home button should be working.


#2963

Bless your soul. Thank you for this!


#2964

I want to purchase a Brook Universal fighting board because the PCB on my Mad Catz TE Street Fighter IV has stopped functioning. I see that most fenders offer the Brook fighting board with or without header connectors.

Should I purchase the board with or without the headers?

what is the advantage of having with the headers?

I’ll be using the fightstick meanly on PC and Xbox 1

Thanks for reading.


#2965

Hi, I have some issues with ps4, when I connect the stick to ps4 works fine but few minuts later stops working, don’t appear the disconect notify but ps4 don’t detect inputs. But if I connect in manual mode pushing 2P the pcb works fine and not disconect.

I think it’s provably what happens with jassens panzer :*
PD: Mine it’s not a panzer but I have the same pcb.


#2966

I’m experience this problem with my Panzer 3 as well


#2967

So I don’t have time to search this thread for an answer and would appreciate anyone’s input on this.

Arcade Shock sells a Brook UFB modding kit. If I purchase that kit for my TE stick, will it just be plug & play?

I am looking for an option NOT to solder.

Thanks!


#2968

I tried updating the Brook UFB but with windows 10 being the awful operating system it is the updater stopped responding and closed this has caused my UFB to not work on any system but its still picked up in its HiD transfer mode. Attempting to update the board now gives me a failed to write error. Is there anything I can do about this or do I just have to buy a new one, thanks in advanced for any answers.

Edit: I’d Like to mention before this I’ve had no issues with the UFB and it’s been great hopefully this issue can be resolved.


#2969

@Axenotgood
Please change in another port and try to update again.


#2970

You might want to look into this if you plan on using a UFB on your TE stick

http://forums.shoryuken.com/discussion/comment/11561259


#2971

Hello! What is the J2 connector on PCB used for? is it for the joystick?


#2972

I tried other ports with no luck Tomorrow I’ll try on another computer and see if that helps thanks for the quick response.


#2973

Windows 10 is not an awful operating system. I use it every day without issue, and have zero issues with using the firmware updater software to adequately update my UFB boards. The issue, as it seems, lies within your PC’s configuration—perhaps even BIOS settings. Good luck updating on another PC.


#2974

I’ve tried on 2 computers and both are giving errors on my current computer it’s ‘set address has failed’ in the device manager. I’m using a printer cable currently (I have tried different cables to no avail) as I don’t have the usb end of the cable that’s soldered on from my TE-S (the breakaway part), could this be causing the issue?

edit: I removed the other cable that was soldered on using only the printer cable this made there be no issue connecting to a new computer and updating. Should have realized having a 5m cable soldered on might be a bit of a sink. Thanks for all the help glad to have my stick up and running once again Im excited to finally be able to jump in to dbfz.


#2975

Anyone have the beta fw 5.50 for the ps4? If so, has the UFB shown signs of requiring an update?


#2976

Can I anyone tell me what 5 pins on the J9 connector are pinned for the joystick?


#2977

You know it’s on Brook’s website: http://www.brookaccessory.com/detail/06960737/


#2978

Hey Guys quick questions about this card (I have a hitbox Panzer, I updated it to 1.6 on my windows).

Question 1:
On DBFZ, I noticed something strange: the LT and RT are inverted, and so are the RB and LB. (in a nutshell the default configuration for the 8 buttons is:
X | Y | RB | LB
A | B | RT | LT

I wonder if it is normal or not that the left and right B/T are inverted? (maybe it is not a bug but a feature? :wink: )

If it isn’t, what software, on my windows, should I use to reconfigure that? Any video tutorial?

Question 2:
So I have this macbook, I usually streamed games from my windows desktop to this mac laptop (and play in bed :slight_smile: ). I used a Razer with lots of buttons and it worked fine for other games.

Now I would like to do the same thing for DBFZ. When I plug the Panzer hitbox into, in the system reports I do see it under “hardware -> usb” with the name “P4 Wired Gamepad V1.6”.

Then I go to Steam, go to big picture mode, but here it is super strange: It shows the controller in the controller menu, I am able to set the buttons I am interested into, but I cannot save the configuration!

Ever weirder: When I select DBFZ to stream it, usually you can configure a controller for the game if you check “base controller”, but here nothing appears!

Anybody tried to do such thing!?


#2979

In Windows, these show up as XBOX One Controllers (verify with joy.cpl) and on Mac it shows up as P4 Wired Game Pad; that is normal.

I never used Steam on my Mac before I got rid of it, so I can’t help you there. In windows, what do the buttons show up as in Joy.cpl? Top row should be… 3465 bottom should be 12 then the top bar full out, then full 0 (If i recall correctly).


#2980

Yes, for windows, for “Game controllers”, it does appear under “Controller (Xbox One For Windows)”.
And I confirm that the top row is 3,4,6,5
second row is also 1,2,empty z-Axis, full bar z-Axis.

So ok this is the right configuration, it is then DBFZ that is weird (if you try to go in a lobby, it uses the default controls of your board, not those you modified, so if you try to look at the quests, it is the RB button, which will be, under joy.cpl format, the “6” (While to me, RB means right button so I pictured it more on the top right, so “5” here). Strange. Maybe I screwed up somewhere the configuration just for this game…

Too bad to the Mac. I tried to install https://github.com/360Controller/360Controller but it doesn’t see it (I guess it forces it as a Playstation controller when I plug it)