Brook Universal Fighting Board Thread


#3021

Oh I gotcha. I thought it was just personal non tourney use, my mistake.


#3022

The Brook UFB lets you force modes instead of letting the board proceed to auto-detect which mode it should use. Buttons that you hold while connecting the cable to the USB port: 1P for PS3, 2P for PS4, 3P for Xbox360, 4P for XboxOne, 1K for WiiU(Pokkén)/Switch, 2K for Xbox Classic.

The ability to force a mode is independent of anything the host platform has to say. Worst case scenario there won’t be a driver/support for the chosen mode. If you specifically don’t want XInput, manually choose either the PS3 or the PS4 mode. I’ve never seen a case of the PS3 or PS4 modes of the Brook UFB not being plug-n-play on a Windows PC (i.e., never had to install drivers that weren’t already installed).


#3023

If a tourney is hosting a game that needs something other than XID in 2018 and they’re not providing options, I’d say that’s on them, not you - basically every retail stick now ships with an Xbox 360 mode.


#3024

Hi there. I seem to be cursed with issues when it comes to this board, and I’m not sure what to do anymore.

My stick seems to disconnect randomly while playing. The board is updated, and the disconnects can happen almost immediately after plugging it in, or up to hours after.

The craziest part is that I replaced my UFB with a new one after the disconnects became more frequent. The new board worked fine, but then started disconnecting like the old board…

My stick currently has a Cat5 passthrough, but these issues have persisted with a Cat5 passthrough, a USB passthrough, no passthrough, with a powered USB hub (as was suggested to me before) and honestly everything else I’ve tried.

This leads me to believe the issue lies in my wooden stick case, as crazy as that sounds.

Is it possible that the placement of the UFB is causing it to short circuit? Maybe my passthrough has caused permanent damage to both of my UFBs?

Is there any tool I can use to run tests on my UFBs to try to find the issue?

If anyone here reads though this and has an idea as to what it could be, bless you.

Any and all help is appreciated. :slight_smile:


#3025

@Maximiliano Could it be the actual joystick that is the issue? If you’ve done two different boards, I doubt it’s the PCB. Most likely the problem is with the lever itself. Do you have another one you could put in to test?


#3026

What do you mean by “lever?” I may know it as something else.


#3027

The Sanwa/Hori/Seimitsu Joystick you’re using in the controller.


#3028

His entire arcade stick disconnects from the console/PC. It’s not just his “stick,” as he mentioned. That initially threw me off too.

@Maximiliano have you tried testing to ensure your grounding is correct? If things aren’t grounded properly you’d experience all kinds of cutout (inputs, connections, etc).


#3029

It has a Sanwa joystick with the Pheakmods Link modded onto it. You’re referring to the joystick PCB though, right?


#3030

Dude, does your joystick inputs not respond in-game, or does the whole arcade stick disconnect from (or is not recognized by) your PC/console?


#3031

I plug it in, it works like normal for a random amount of time, then the arcade stick becomes disconnected from the console somehow.


#3032

Just the stick or the buttons don’t work either? That is what they are asking.


#3033

Nothing. Same as if it wasn’t plugged in at all.


#3034

Ok so that’s a total disconnect. Thanks for clarifying.

First off…when was the last time you updated the firmware on that UFB? If the answer is not recently… Do that. Like right now. That means: 1. make sure you have signal and ground connections to the Home and Select buttons,
2. Download the latest firmware from the Brook website, and
3. plug a USB A to B cable from your UFB to your PC or Mac

Firmware updated? Issue persists? Ok, let’s proceed…

  1. What device(s) are you using this stick with? PC? If so, which OS? Connecting to front case ports or rear ports on motherboard? If console, which one(s)? If used on multiple devices, does the issue persist on all? Have you confirmed this on other people’s like devices?

  2. You say that you’re using a Ethernet passthru. You’re only using that with a Brook UFB? If so, did you previously use that with something like a MC Cthulhu or a PS360? If not, what is/are the other board(s) involved in the equation? Regardless of answer…Please post photo(s) of the setup.

  3. Have you gone through ALL of your connections to the Brook UFB? ESPECIALLY the G, D+, D- & V connections from the passthrough to the UFB? Are those connections soldered on or terminated via a crimped pins header? If soldered, have you checked the joints? If crimped, have you checked the pins? Either way, have you tested all these with a multimeter? Please post photos of the USB wire connection to the UFB.

Let’s start with that for now. Hopefully we can fix this for good.


#3035

Sorry for the delay.

I use it mainly on PS4. It has disconnected on multiple PS4s, including at EVO and NEC (I thought I fixed it after EVO :expressionless:)

It used to be connected via a custom USB to Ethernet cable I made, specifically because I thought being connected by USB was causing the issue and wanted a more solid hold with the passthrough. It is now soldered directly onto the board now. (@Gummo was cool enough to do it for me at NEC, although it unfortunately didn’t fix the issue).

A few pictures -https://imgur.com/a/w1HSG

I refitted and tightened all the screw terminals again to make sure they were connected.

I haven’t used a multimeter yet. I would need a walkthrough on how to test it if I do.

Pictures above.

If you need any more pictures or information, please don’t hesitate to ask.


#3036

Thanks for the photos. I am not one to talk shit about Gummo’s work, so I’m not going to. However, based on what I’ve read/seen (so far) either the solder joints for G/D+/D-/V @ “J6-1” OR the punch down terminations at the RJ-45 pass may be suspect.

I know you said you’ve tried connecting the board outside the scope of this passthrough, but can you please get yourself a USB A to B cable (a USB printer cable will work in a pinch as they use that exact layout), connect the B side to the USB connector of the UFB labeled “J6,” and the A side to a known good USB port on a PC? Launch the Control Panel app then select Devices and Printers.

You should see in the list of devices an entry for an Xbox One controller (the default mode set by the UFB when connecting to a PC). Right-click on that entry and select Game Controller Settings. Then click Properties. Now test EVERY FUNCTION that’s connected to screw terminals on the UFB. That means ALL joystick directions, and ALL buttons.

Let me know what happens when you do that


#3037

So…@Maximiliano what was the result of your testing based on my last post?


#3038

Oh wow, I’m so sorry for not responding. Work and school have been so hectic lately that this completely slipped my mind.

No, I haven’t yet. I will have time this weekend though, as the big grad school project I’m working on will be done by then. You’ll definitely hear from me then.

Again, I apologize for not responding before. I really appreciate your help.


#3039

No worries, man. Just wanted to confirm that you’re still breathin’ :wink:


#3040

I have recently put together a fightstick (well, hitbox) with the UFB. While trying to get it to work on my PC, but the default, Xbox 360, is not detecting the controller properly. Forcing the system to recognize the peripheral as a 360 controller doesn’t make it work.

While I can force it to see the controller as a PS4, it doesn’t work correctly for all games, which is why I desperately want the Xinput support.

Has anyone else had the issue I’m having?