Brook Universal Fighting Board Thread


#3041

The default mode for the Brook UFB on PC is Xbox One. You need to hold 3P to force Xbox 360 mode upon connection. Are you holding 3P while connecting?

Have you done a firmware update to the board recently? Whether the answer is yes or no, download the latest version and flash the board again regardless.


#3042

Either XBox 360 (3P) or Xbox One (4P) come up with the same issue (I thought 360 was the default one? Whatever).

Yeap, flashed it just yesterday.


#3043
  1. Check all of your connections.
  2. Download another update file (yes, again)
  3. Flash it again.
  4. Test it again.

Something may have gotten hosed in the update process.
On a side note: what version of Windows are you running on that PC? If it is Windows 7, that will change this conversation significantly—as there have been issues reported with the UFB getting properly recognized on Windows 7 PCs


#3044

Yeah, Windows 7.

Sorry, should’ve stated that from the get go.


#3045

Time to upgrade.


#3046

You mean downgrade?


#3047

Amusingly, you simply mentioning that the default is Xbox One got me thinking about that being separate drivers than the 360 controller.

A little digging and I find the driver (no longer hosted by MS themselves) on Techspot. Installed that, plugged in Xbox One controller, and it works. Then I plugged in my hitbox with the UFB, and it detects as an actual Controller. Test in SFV, DBFZ, DOA5LR… all of it works flawlessly. Huzzah!

Thanks.


#3048

Glad the search function will works. Good job on getting back up and running :+1:t2:


#3049

Gentlemen, I hope someone here can help me.

I´ve purchased a UFB and, after wiring it properly, evertything works well but left/right directional.

I´ve triplechecked wiring ant it looks perfectly ok. i´ve checked for bad tracks on the board but i´ve noticed it´s also perfect (I tracked it from the bourne to the big chip in the center and it´s ok).

Are there any further troubleshooting steps I could take before to start a (boring/too long) return/refund process?

Thanks in advance!


#3050

Maybe try reflashing the firmware? And is it on all consoles the UFB supports or just 1?


#3051

Thank you wikidone0321.

I already tried reflashing the firmware. No success, left/right still doesn´t work.

I tried on PS4 and PC. I have another boarde (Brook PS4+Audio) that is working perfectly.

Regards!


#3052

Hmm. Maybe try taking wires from the left and right input off of the ufb and a ground wire and one of them at a time to the ground while plugged into the console and see if that does anything.


#3053

Also did you redownload it or did you just use reuse one already downloaded? If you just reused the download try downloading a new patch and try again.


#3054

Tnx, wiki.

I´ve tried short L/R with GND and I redownloaded the firmware before reflash.

I´d like to try previous version, just in case, but haven´t found it for download.

Regards!


#3055

Well the previous version wouldn’t work without the 8 minute timeout. They release new firmware everytime Sony patches it. So the shorting of the wires didn’t work either?


#3056

Quick question, does the entire board need to be wired up in order for it to function? I wanted to update the board before finishing making my arcade stick and so I only plugged in the PS and Options/Select button. However, no button presses are being recognized; I even plugged in the left/right direction buttons and plugged it into my PS4 and still nothing. The PCB is being picked up by my computer in device manager (albeit with an error), so there is some type of connection. Is the PCB laid out so that it’s not a complete circuit unless all of the 20 terminals are filled? Or perhaps did I miswire my connection? as I am using a USB-B cable spliced into an Ethernet cable and then running it through the neutrik passthrough?

Figured I’d ask before I go into trial and error mode.


#3057

It works without being wired up completely, and you can certainly update it that way. As long as you wired ground to the buttons properly, the only likely problem is that there’s a mistake in the ethernet cable wiring. You might want to try connecting a USB cable directly to the Universal and plugging that into a computer to find out if that’s indeed the trouble.


#3058

So I picked up a USB-B to USB-A cable just to test the PCB and the light is coming on now, which is good, but the computer is not picking it up (no longer shows up in device manager) and nothing happens when I try to firmware update.


Any additional ideas and or thoughts? should I go for a USB 3.0 cable?

UPDATE: Additional info,

So I re-spliced my USB-B to Ethernet cable and here is what I am getting.



So it is being picked up by my computer (with an error) however, the blue LED on the board does not light up.

With a normal USB-B to USB-A cable this is what I get.



So the LED lights up, however my computer does not recognize it.

Neither connection registers any button presses.


#3059

Are you able to try a JST connector on the alternative USB header? USB to ethernet to USB wiring works fine done right (it’s the basis of dual modding to an MC Cthulhu) but if you connected the VCC to the ground in error it’s possible the board has been damaged


#3060

I ordered one of these to connect it to the G/D+/D-/V connector on the board.


Wasn’t sure if the pins would fit this connector or not, but I need it for another project I’m working on anyways, so no harm if it doesn’t work.

In terms of the wiring of the ethernet header, I can show you what the ethernet to usb-a side looks like and how I wired the wires to the custom cable if that would give any more details.

UPDATE: additional info

The cable that goes to the console was wired like this.

So I took the corresponding wires that matched here.


Which would be:
Black ~ Brown
Red ~ Orange/White
Green ~ Blue/White
White ~ Blue

It has always been wired up in this manner when testing, and all wires were individually wrapped when tested, so little to no chance of two wires crossing. I did plug it into my ps4 to see if it would respond but nothing happened.

I still have a couple of troubleshooting tests I can do off the top of my head:

  1. Change the Ethernet side of the spliced cord
  2. Change the USB-B side of the spliced cord
  3. Wire directly from the 4 pin connector on the board
  4. Give up and try to contact the seller for a replacement board/buy a new one

Though let me know if anyone has any better ideas as 1/2 of these require me to cut more cables and 1/4 is an extremely expensive option