Brook Universal Fighting Board Thread


#3061

Things that is often forgotten that you always want to take a factor in is impedance and interference.
We will skip interference at the moment and focus on impedance.

So the issue could be impedance, too much of the wiring properties (such as re resistance of the wire) have changed to send a proper signal.
Typically USB isn’t that picky, but you are re-purposing a Cat 5 Cable with thinner wires, and the D- and D+ is not in a twisted pair.

How is the board handing a normal A to B USB cable?


#3062

It might simply be that the board isn’t getting enough power via USB. You could try plugging it into the back of the computer if you’ve been plugging it into the front. Or you could try to update it on another computer, or test to see if it works at all on a PS4.


#3063

So as it stands, when plugged in via normal USB-B to USB-A it seems to be getting power, but it is not being picked up by the computer (so I assume no data is being sent). I have tried plugging into both the front and back USB 2.0 and 3.0 slots. I have a separate cable coming in the mail today that I ordered a few days ago before I encountered these problems that I am gonna try when it gets here. As far as trying to updating it on another computer, I’ll give that a go. When I tested it on PS4 it was via the spliced cable, so I will try the USB-B to USB-A cable next.

If re-purposing a Cat 5 cable could be the source of the problem, would wiring my own cables into an empty ethernet socket be the way to go? I would assume I would have to make sure to twist the data cables into a pair.

UPDATE: Additional Info

Plugging into another computer with both cables has yielded no new results, the same thing happens on my main computer happened on the laptop, light comes on but not showing up in device manager (when plugged in via USB-B to USB-A cord) and no light but shows up in device manager (when plugged in via the spliced RJ45 board). Now I just wait for that 4 pin connector to come in the mail so I can attempt to wire it straight to those terminals.

I did fail to mention earlier that there is a small imperfection on the board which in hindsight kinda looks somewhat like burning from a soldering iron. It seemed/seems pretty minimal so I didn’t pay it any mind. Is this possibly something I should be concerned about?

I thought it was dust or some residue or something, so I didn’t pay it too much mind.


#3064

I play on PC and have several custom sticks using the UFB. All of them except one prevents the PC from turning off the display, or wakes the PC shortly after the display has been turned off. My oldest custom stick, a custom hitbox was the only one without this issue. Today I’ve updated the firmware to the latest one on that stick and it now has the same issue. I’m using 64 bit Windows 10, and wondering what it is that could be causing this? Anyone have any ideas? Unchecking “allow this device to wake the computer” and removing it from the list of devices allowed to wake the computer using the command prompt haven’t been able to fix the issue.


#3065

I just ordered one to convert my 360 Hori VLX Premium for Ps4 mainly. Any suggestions on how voice chat would work with friends? Would I need to connect a second controller and then do a chat party or something?


#3066

Buy a USB headset. Personally I use https://www.amazon.com/gp/product/B076DWX58X but you can just buy any usb headset that supports ps4.


#3067

Okay, so this is embarrassing. I went through a large move a month ago, and I ended up losing the stick in question.

Good news is I found it and did what you asked!

All buttons and directions work perfectly, although my home button opens up Steam, for whatever reason.

Anything else you ask of me will be done quickly.

Again, I apologize for the delay. I didn’t want to post again until I had done the tests you asked me to perform. I would hate for you to think I was wasting your time.

One more thing: I replaced the passthrough just in case.


#3068

Couple questions:

  1. Is there any difference between the PS3/PS4 Brook PCB and the Universal one, as far as PS4 games go (I don’t care about audio support)? Apparently the PS3/PS4 one comes with dual analog support, but I’m not sure how useful this is for fighting games.

  2. Is anyone who’s playing SF 30th having issues with the touchpad situation? As I understand the PS4 version of 30th maps start(?) to the touch pad button? I’ve heard some gripes about it but I don’t know if it’s a real pain or easily circumvented.


#3069

I remapped start to 4P, FWIW. Could probably work something out with the reassign on my Hori, but it’s handy for execution for taunts and fakeouts.


#3070

I can tell you the Steam opening up part is due to its reacting to the Home button of an Xbox360/XboxOne controller…


#3071

It’s a Brook UFB, so that makes sense.


#3072

Does anyone know if the ufb has a anologe to digital converter built in? Wanted to know if anologe push buttons work with the ufb?


#3073

if i buy the ufb with pin headers added can i still use the screw in terminals?


#3074

The inputs are momentary on the Brook, so no.


#3075

pretty sure you can :slight_smile:


#3076

Hi all,

I am having an issue with my Brook Ufb, I previously used a Sanwa JLF with silent switches and all was well. Seeking more speed and accuracy I switched to the optical Hayabusa stick (purchased August 2017) which has a 6 pin connector and it worked great.

Suddenly a couple days ago when I plug in the stick it comes on but when I move any directions on the Hayabusa the whole board goes off and comes back on.

After checking all my connections and trying with my UFB that’s used in a hitbox I have it also does it on the second board I came to the conclusion the issue is with the Hayabusa.

I THEN put my Sanwa switches in and try to use them with the 5 pin connector and the board doesn’t come on. THEN I try this same thing with my hitbox Brook UFB and the Sanwa switches work just fine.

What in the WORLD is going on? It’s as if my first UFB only accepts 6 pin sticks now. If someone can shine some light on this issue it would be greatly appreciated.

Thanks


#3077

Hoping to get some help getting my Brook UFB modded fightstick to work on my Xbox One. I paid a guy on these boards, @RoyalFlushTZ to do the mod (I’m not very technical) and he seemed to know what he was doing, so I think it’s all hooked up right.

The stick works fine on an Xbox 360 (I play a lot of Soul Calibur V), and I’ve successfully downloaded and updated the latest firmware. When I plug it into my XB1, however, the controller does nothing. I’ve even tried holding P4 while plugging it in, to force Xbox One mode. (all 4 quadrants of the light around the Guide Button do light up, though).


In order to troubleshoot, I tried doing the JOY.CPL thing I’ve seen in this thread. When I plug my stick into my PC, the JOY.CPL list does not populate showing the controller as an XB1 controller.

I tried doing the “hold a button while plugging it in” thing, and the list did populate with P3 Controller, POKKEN Controller, Xbox 360 Controller, and all the other ones (depending on which button I’m pressing, of course).

So it seems like everything else works, just not the Xbox One functionality. But I’d really like to use this thing plugged into my Xbox One. I’d appreciate any help or suggestions that people here could render. Thank you!


#3078

Wanted to upload a few pictures of the insides of the stick. Figured it might be easier to solicit advice (see post above) if you all could see what was actually wired to what. Again, would really appreciate any help or suggestions in solving my “everything except the Xbox One functionality works” problem!


#3079

Did you try pressing the Guide button once plugged into the Xbox One?


#3080

Just tried it again, and I’m afraid it was the same result. Tried the USB port on the side of the Xbox One, and a USB port on the back of it. Plugged in the arcade stick, the lights around the Guide Button turned on, but that was it. No response from any inputs. Pressing the Guide Button didn’t cause the guide menu to come up nor make the other inputs start doing anything. I then tried holding P4 while plugging in the arcade stick to force Xbox One mode and tried the whole process again (both USB ports, pressing the Guide Button, holding the Guide Button…)

So, yeah, not sure what to try next. I “discovered” this issue when I tried playing Killer Instinct on a friend’s Xbox One, but now I’m trying the stick on my Xbox One (same results), so I’m pretty sure it’s not the console. Please let me know of any other troubleshooting steps I should try!