Brook Universal Fighting Board Thread


#3102

Are you sure u didn’t connect the turbo led instead of the actual turbo button pins?


#3103

oh… maybe?

https://cdn2.bigcommerce.com/server500/d90a4/product_images/uploaded_images/ufb-01-en.jpg ??


#3104

Mystery solved, apparently the autofire is not supported on all buttons, I was testing button 6 on my pc (maybe select or start) and the turbo key was not working, while using another button worked immediately


#3105

What does it mean when I hook up my brook ufb stick and the blue light comes on, but doesn’t register on ps4 or pc?

Also, what would I need to acquire in regards to adapting the internal usb connector on the brook board to to be able to use the rj45 cables on a brook ufb stick?

I tried an rj45 to usb adapter on Amazon and it didn’t work.


#3106

Post pics of install


#3107


#3108

Wireing looks good. When you say it doesnt register you mean without the rj45, directly to usb right?


#3109

Right, I have 2 separate issues. I have a Qanba hooked up to a Brook ufb that used to work but all in a sudden when I hook it up the blue light on the board comes on but doesn’t register with any devices.

The second situation is the hitbox in the picture where I have a usb b cable hooked to the brook board (this would normally go straight to the usb neutrik), then I have a usb female to rj45 male adapter cable hooked to that usb cable which finally goes to the female rj45 neutrik port. When all of this is hooked up the blue light on the board comes on, but no device is seen.


#3110

Ok, for the qanba it might have cable damage. Start by trying a new usb a cable directly from the sanba ufb to the ps4. The blue light will come on even if both data lines are damaged afaik.
For the other stick it depends how the adapter thing maps your usb wires. Im assuming youre trying a ps360 style rj45 to usb on the outside but those are made for a ps360 board or a brook retro board. Theres noway to know if that adapter maps the lines in the same way. I dont understand why you dont just use a usb neutrik though.


#3111

I have 2 usb cables and have tried both and they both work.

Yes, it is a ps360 cable.

I have been using a regular usb neutrik for sometime, and over time the connector gets loose to the point to where it is moved a bit the controller disconnects and reconnects and I end of up having to buy a new neutrik connector. Plus I’ve always like the locking boot feature of the rj45 cables over the naked usb b version.


#3112

Does anyone know how it would be possible to power the Brook UFB board with a neutrik rj45 connector?

Has anyone accomplished this?

EDIT: n/m, figured it out


#3113

I recently built a hitbox and have been experimenting with the 2 different SOCD methods on the Brook Fighting Board +. Curious what your opinion is on the last input used method vs the canceling left/right out.


#3114

Hello, I’m going to buy a UFB board soon to upgrade my Qanba Q4raf and I have a few questions :

1 - I don’t have a daisy chain cable for the grounds on the regular buttons. Can I just plug all the ground in the same screw terminals ?

2 - What do I need to do to fit my USB cable into the PCB ? I read that it is super easy to fit it in.


#3115

@_Xan

  1. Yes you can, it might get a little tough to fit that many wires in a single screw terminal though.

  2. The brook ufb takes a usb type a connector. so you would need a usb type a - type b cable to connect your ufb to a neutrik or directly to the console. These are typically referred to as printer cables, as most printers from the late nineties to mid 2000s used these (before wireless printers were popular). You can always solder directly to the board as well if you don’t want to use a connector.


#3116

Bro you want to use your hitbox where left right equals neutral, and down up equals up. In games like Tekken, having that type of SOCD allows you to do advanced techniques very easily. Like the Korean Backdash for instance or the Electric Wind God Fist. You need the SOCD I described in order to be able to do the shortcut or simple way of doing those moves.

For example, for the Korean backdash in Tekken. If you hold back and just hit down, forward, down, forward, down forward, you get a Korean backdash. It takes stick players a while to get that down. With Hitbox and SOCD, you can master it in a day. I started doing it using both hands then eventually got to where I could do it with one hand on player 1 and player 2 side. You still have to practice it, as the cadence for the “down, forward, down, forward” is not as simple as it sounds, there’s still a technique to it. Anyway, good luck and stick with standard SOCD!!!


#3117

Wow. I love the button mapping presets activated via PS + [specific button] used on the Neo Geo Mini mode (just read about the new firmware update). I wish something along such lines existed for all the other modes… The alternate mapping I miss the most is one where 3P would be mapped to L1(LB) and 3K would be mapped to R1(RB), instead of the usual 3P -> R1, 3K -> R2. This alternate mapping would have 3P -> L1, 4P -> L2, 3K -> R1, 4K -> R2, doing away with both SNES-game-related and non-fighting-game-related headaches involving the Left and Right controller buttons. ^^
@GOGO.Zippy @Brook_Engineer

Button mapping suggestions I find worthwhile (only actual differences mentioned):

  • Alternate mapping 1: 3P -> L1, 4P -> L2, 3K -> R1, 4K -> R2

  • Alternate mapping 2: 3P -> L1, 4P -> R1, 3K -> L2, 4K -> R2

  • Default mapping (just for reference): 3P -> R1, 4P -> L1, 3K -> R2, 4K -> L2

I hope Brook cares to implement these one day… :slight_smile:


#3118

L3 and R3 shortcuts too :sob:


#3119

Hey today I had this problem where I connect the stick either on a console or PC and it doesn’t work at all, I opened the stick and when I connect the cable to either a console or PC, the board lights up but nothing works, what it could be? I have pictures


#3120

When you connect it to PC, does it appear in device and printer? Can you force a console by holding a button when you plug it in. Maybe update again.


#3121

Nothing happens at all, like it doesn’t detect the device at all, I forced different consoles mode and nothing. It could be that the USB cable is passing voltage but not the data?

Update: I tried another cable and same thing, console or PC doesn’t detect the stick, PCB bar lights up though