Button not working on a round 1 TE Stick


#1

I need help with suggestions on how to fix my b button because it doesn’t register inputs anymore. I already tried changing the button and changing the quick disconnects to no avail.
Does anyone know what could it be causing the problem?


#2

is anything else loose in the chain? check every connection. my start button came loose and it made the head set jack stop working.


#3

If tried swapping the button to no avail then it could be the wire that goes to the block or the ground.if u tried swapping the button then I’d lay odds it’s a bad wire. Or worse a trace on the pcb.


#4

I already tried swapping the buttons and it didn’t work.

I should have said on my first post that for some short periods of time the button will register inputs (a round or two), however 90% of the time the button doesn’t work at all.

How could I test if its a bad cable? or how could I fix it?


#5

Try pushing down the jst connectors and the pin connections. most likely it’s loose. use a tiny flat blade screwdriver.