Button works in the menus, but not in game?


#1

Has anyone else had this problem?

I soldered up a controller, and thought I’d test all the connections before slapping it into the stick…

All the buttons work fine when I touch the signal and ground together.

when I go into the game, everything works the same except for A, B and Y; I can’t use them for attacks.

halp?


#2

it’s voodoo magic


#3

I already tried sacrificing a chicken - should I move up to a goat then?


#4

Gotta level the game up, go baby.


#5

I couldn’t find a goat,so I had to settle for my neighbors cat.

Still no go… but that little fucker sure put up a fight.


#6

also, you’re not helping.


#7

which pad did you wire up?


#8

Check your button settings in the game, they might be out of wack or set all weird. Worth a try.
GL


#9

Thread name is a little misleading. Touching the signal and ground with a wire and having it work just means the PCB is fine, the problem is then most likely bad wiring between the PCB and the buttons (or between the buttons, if you daisy chained).


#10

I had the triggers on the madcats controller cause some funky button issues. I had them set at dead center but they were never 100%

I ended up removing them all together and using a resistor.

which pcb is he using?


#11

The issue I was having might have been related to the triggers. I still had them on there, but possibly not neutral…
I am using the gamestop POS model BB-070.

I wired the bitch up to my old X-arcade stick, and she’s working like a dream :smiley:

Thanks for your advice, regardless… this site is precious!


#12

Trigger problems are basically voodoo magic when you don’t understand electronics. :sad:


#13

So I was right all along.

Chalk one up for me!