Can a bad stick case affect inputs?


#1

So I’m in the process of modding the Datel Arcade Pro(Mod thread: http://www.shoryuken.com/showthread.php?t=222084) and I’ve gotten all of my buttons hooked up (Sanwa OSBF-30s) via all quick disconnects.

After finishing the buttons, before moving onto the joystick I plugged it in to make sure everything was working and I’m having a bit of a problem.

Every button works just fine and I’ve gotten the layout how I wanted it. I’ve mashed all of the buttons 1 at a time to make sure none of my disconnects are touching and no inputs are lost. I gave the stic a few love taps to see if the jarring would mess up my disconnects and it’s all seeming just fine.

The problem comes when I try to hit more than 1 button at a time. For example if I’m hitting LP and MP for an EX move(as an example): It generally works fine and the inputs come out at the same time but, every so often it comes out like a plink. This goes for any time I hit more than 1 button at a time. Another example is I’ll mash all the punchs and most of the time I’ll get:
:lp::mp::hp:
but sometimes I’ll get:
:lp::mp::hp:
:mp::hp:

At first I thougth it was me and my timing so I went back to my TE and mashed all the punchs and I got :lp::mp::hp: all day long.

Next I thought maybe the PCB sucked and couldn’t handle the inputs but, then I pushed the buttons slowly to make sure I was hitting all of the buttons at the same time and I’ll get :lp::mp::hp: just fine.

So my last guess is that it must be the cheap plastic case of the datel. If you push hard enough the case does have some “give” and I’m suspecting that this little bit of give is causing me to hit the buttons at split second intervals from each other. The other reason I think this is because even with OSBF-30s the buttons are loud, granted I have a hole in the case where the joystick goes but, even covering the hole doesn’t stop the noise very much.

So is it possible that the case is just too low quality and that’s my problem? Or could it because my brand new OSBF-30s are much more sensitive than the ones on my TE?(I don’t think this is possible but it’s worth asking) Or is it something else I haven’t thought of?

So to summarize:
Inputs SOMETIMES come out as plinks
There are no lost inputs or extra inputs(ruling out broken buttons or PCB)
I never get more than 1 input if I’m only pushing one button (ruling out disconnects touching)
It’s not my excecution because I’ve done it back to back on a different stick with the same brand/model buttons

Any Ideas?

also, while we’re on the subject of trying to fix this is there a way to dampen the sound?


#2

I doubt it’s the “give” in the plastic. Seeing how light the Sanwa buttons are (you only need to stroke it and it’ll register as an input) i doubt you’re hitting hard enough for that to happen (and if you are, stop hitting your buttons so hard! =P )

Your example is only using the punches, have you tried all 3 kicks? maybe just one of your punch buttons is defective (even new parts sometimes have a defect right out of the box) and is messing up your inputs.


#3

A case can only affect button/joystick inputs if you’re not used to it or find it uncomfortable. Unless it’s made out of noodles or something that is prone to collapse over time.

For example, my inputs when using something like a Hori FS1 or Namco stick are more likely to fail because I find the triangular design uncomfortable. When swapping over to a box joystick (like a Mayflash or Dreamcast stick) my inputs are precise.

In short (assuming that your quick disconnects, buttons, and wiring is all in good order) it’s all down to personal preference.


#4

You might want to check your soldering. You might have solder just barely grounding those two buttons.


#5

another thing to check is the connection between the disconnects and buttons. if they slide on/off easily, you might want to use pliars to tighten them so they make a solid connection. bending the button terminals is also another option.


#6

Kelter try opening the case and rechecking all connections to make sure they are ok. A malfunctioning QD ie one that slips a bit might be the cause of your problem. I had a similar problem with one of the leds in my buttons and the problem was just that - a malfunctioning QD.


#7

lmfao


#8

I’ve noticed that 3xP and 3xK is a lot easier to hit consistently on my friend’s TE stick than on my modded Mayflash, which is basically the same issue you’re having.

I always thought that it was simply the difference between a metal and plastic panel and the difference between the Vewlix and HRAP1 button layouts.

Attaching metal weights underneath the plastic panel of your Datel stick can help muffle the loud hollow noise that the buttons make.


#9

It can happen any time I try to hit more than 1 button at a time. No matter which 2 buttons.

I definitely don’t feel uncomfortable and aside from the noise it doesn’t feel any different. It uses the mayflash body and it’s just as flat as the TE.

Like I said it happens any time I’m hitting more than 1 button. Every button can be mashed cleanly by itself with no extra or lost inputs. It’s when I’m hitting 2 buttons at a time that I get a plink rather than just 2 inputs.

I don’t think it’s the connection because of the reasons I’ve already mentioned. Everything works fine it’s just when I hit 2 buttons. But, I will check them reguardless.

What do you mean slipping? as long as the metal is touching and it doesn’t fall off why would there be an issue? And again I’ll refer you to the previous reasons why I dont think it’s the disconncts but once again I will check them out.


#10

The discomfort can also be subconscious as there is a difference between the joystick and button placement on a TE and Mayflash. Example:

I recently Sanwa modified a Mayflash for a guy I know who had previously gotten used to his TE. He couldn’t get on with the Mayflash at first because his natural hand position on the stick was slightly off (due to the TE). But now that he’s gotten used to it he now prefers the modified Mayflash over his TE. True story.

Now, you’ve said yourself that there’s nothing wrong with the wiring or buttons, and you’ve checked the PCB, so therefore the problem must be coming from you. If in doubt, take a long flat object and use it to press all 3 buttons at once with - what do the inputs in the game say?

There is no way that the Mayflash/Datel shell would be causing a problem unless it had melted in the middle.


#11

Im going in to training mode and mashing out the buttons and i have the problem on the modded stick not the TE stick

someone even gave me a suggestion that it was the angle I was hitting it so I turned both sticks sideways and put them away from me so i had to stretch my arm out and turn my fingers sideways(basically just trying to put myself in an awkward situation)

and it would come out fine on the TE but not the modded stick.

I mean maybe it is the wiring or the buttons but, I’ve tried to elimnate that as a possibility by making sure each button comes out fine by itself and it does


#12

http://img59.imageshack.us/img59/1244/dsc00109ud.jpg

So here is a picture of what I’m talking about. I tried to do Ryus Ultra 2 times in a row and 1 time I got his Ultra and the other his super came out instead.

Here is a picture of the inside of the stick:

http://img204.imageshack.us/img204/6918/dsc00106mb.jpg

What could be causing such a weird timing when the buttons are pressed? Could the wiring really affect that? If it were the wiring wouldnt it just either work or not work? Not sort of work?


#13

i dunno how okazaki likes his setup, but kelter skelter, the connection from the buttons to the pcb, look extremely close.

so, when ure playing they might be touching?

i hate using those half insulated qd’s. i always use full


#14

But if they DID touch wouldn’t I get 2 inputs when pushing 1 button? Like if I mash LP wouldn’t I get some of whatever button is next to it on the PCB?

I’ve never noticed any extra inputs. This is why I’m not convinced it’s the QDs but, it is possible.

How can I test if the QDs touching is the problem?


#15

Remove all Quick Disconnects from PCB except for two Buttons?
And ideally the Quick Disconnects left are not next to each other.

Maybe something happened while you did this?

http://img231.imageshack.us/img231/8981/pinsclose.jpg

Vibration?


#16

Ill try that jdm.

What could have happened by cutting that off? What would cause the issue that I’m having? What’s the core problem?

Because if it is the disconnects I can just solder the buttons to the PCB but, if it’s something else…


#17

There’s no point in having QD’s at both ends of a wire as you won’t be replacing the PCB anytime soon, just the buttons and joystick.

Cut off the PCB QD’s, desolder the horrible line of pins that you’ve got them connected to, then solder each button wire directly to the corresponding PCB point. 10 minute job max. Then see if you’re still having the problem…


#18

Yes, that idea is weird.
Does not look cool either.


#19

Well I don’t know how to solder nor do I have the tool required to do it and if that’s not the issue then I’d rather not do it.


#20

lol “Noodle Stick” is now the name for a flimsy box

To add something useful: You’re going to have to do some more troubleshooting like JDM said, i.e. try just two or three buttons connected at a time. If there is a crossed connection somewhere, you need to simplify things before you can sort it out.

Also, did you have the same problem before you modded? Maybe the problem is nothing to do with the new buttons or wiring, but the PCB itself?