Chimp issue? all wiring/continuity seems ok


#1

I just recently finished soldering my Chimp into a Madcatz 360 TE-S Fightstick, when I plugged it into my Xbox360 it powered up and everything worked perfectly. All buttons and commands worked with no problem.

When i plugged it into a PS3, the xbox light (all 4 corners) came on, however the xbox light kept pulsating and it was not responding to anything, nothing worked. What i mean by pulsating is the xbox light every 5 seconds or so would turn off for a second then blink twice very fast then remain on till the next 5 seconds and this would happen once again. Then randomly a box would pop on the screen saying that the maximum power has be reached for USB device or something similar to that.

When I hook it up to my PC it states that the USB device isn’t recognized and the xbox light continues to blink as it did in the PS3, nothing shows up under game controllers in the control panel or under the USB hub

From what I see, all wiring is correct, all solder points from what I can see look good. I even checked the continuity for every solder point on the TE and the Chimp everyone responds but on the 4066 chip both pins 5 and 6 both say 4.99v. I have ran out of trouble shooting ideas and im starting to think that something is wrong with the Chimp itself, I really hope not, I purchased the Chimp from Gamingnow.com last week, I hope its not one of those bad batches I heard about… any ideas would be very helpful and appreciated thank you

~Serf