Chimp Mod - Killed the original PCB, what now?


#1

Long time listener, first time poster :slight_smile:

So, the subject line probably says it all, but I bought the 360 Chun Li stick and attempted modding it with the Toodles Chimp PCB. In doing so, I ignored the warning of ‘must be good at soldering’ and tried to do it myself anyway. To make a long story short, I completely ruined the 5v hole on the 360 PCB, so, the 360 side of the house no longer works. Since the common ground is still okay, it still works wonderfully on my PS3 and PC. Luckily I have SSF4 and MvC3 on PS3, so, I’m okay for now.

Anyway, so, what are my options here? I thinking I have 3 options

  1. Get a controller, rip the board out of it and solder it in place of the original board
  2. Get a cheap SE stick and hopefully be able to take the PCB board out of and plug it right in where the current one is
  3. Leave it, and be happy something works

I’m leaning towards #2 at the moment, mostly because it’s the lesser of the soldering jobs, but will that work? Like say if I wanted to pick up the WWE Brawl stick, rip out the PCB in it, then burn the WWE stick so no one knows I bought it? Think it would work, assuming its the same PCB?


#2

Pretty sure there are plenty of other places on the PCB you can solder to for the +5v. Worst case scenario is you may need to scrape yourself a new solder point for it.


#3

Pictures! Also, you might be able to find someone that has a working SE/TE PCB for sale or trade in the trading outlet.


#4

Chances that you irreparably burned it are actually pretty slim. Post pictures and/or find a nearby tech willing to help fix it.


#5

Really? There might be a chance!?! AWESOME

Here are some pics, let me know if you need more detail:

And if you say there’s nothing I can do, then I won’t be heartbroken. I’m still under the assumption I’ll be spending money to fix this :smiley:


#6

Shit, I’ve seen MUCH worse than that.
Remove the red wire from the grouping with the USB, and solder it to that large flat shiny area marked ‘U2’.


#7

had a client try this before, just scraped the trace to the 0 ohm resistor and it worked fine, its to the right of the point


#8

Holy crap I’m excited now!! Will try this later as I’ve got errands and such tonight. I’ll post my results. Thank you guys SO much!


#9

This has been a good day for tech talk, hasn’t it? Good luck, Ak47ira!


#10

Okay, so, update, pics can come later, so I soldered the red wire that I was using for the +5v to the big brassy U2 area and plugged it into the 360. This time, still didn’t work, but the chimp only lights blue and red, not green. It did this to me before, but unplugging/replugging solved the problem. Not this time. Any initial thoughts?


#11

don’t plug it into a 360 or console before you test it on pc

always test on pc before you test on a console

try forcing 360 input on pc and see if it registers


#12

It works!!! Turns out the the + USB cable going to the Chimp was disconnected for some unknown reason. Anyway, re-screwed it in and everything works now! Thanks everybody, off to play MvC3 with friends :slight_smile:


#13

I love a happy ending :slight_smile: