CPS3 3rd Strike HELP!


#1

I have a US SF3: 3rd Strike with the CD-ROM drive. I went to turn it on today and it’s stuck at the “Now reading CD-ROM please wait…” screen. What is going with it? I’m playing it through a Impress cab. I ejected the drive several times and it seems to be working because the CD is spinning. I unplugged my jamma and plug it back up and it says the same message. Can anyone help me? Why is it stuck at this screen? Any help will be greatly appreciated. :sad:


#2

Sounds like the drive is busted or possibly dirty, try cleaning the lens maybe? Another possibility could be that it isn’t getting enough power, verify (with multimeter) that voltage going into the gameboard is +5.1 VDC and adjust if needed.


#3

Ok i’ll go try both. Then i’ll post with updates.


#4

Still stuck @ the loading screen!!

Well i tried everything and no luck. The voltage is fine & i tried running a lens cleaner through the cd rom drive and it still doesn’t work. Is there a way I can try another cd-rom drive? Where do I get it & what brand and model should i get?


#5

Does anyone know the speed of the CD-ROM drive?