Cthulhu mc works on ps2, but nothing else


#1

I’ve installed a cthulhu mc into a stick as a dual mod. Although it works flawlessly on ps2, Saturn, snes and dreamcast don’t recognise it at all.

I’ve continuity tested the board from the buttons, and I’ve tried re-crimping the rj45 cables and continuity tested those. I think it might be an issue with the board, possibly whatever auto-select mechanism it uses isn’t working. Has anyone seen this issue before?

The firmware has been updated to the latest version successfully. One thing I have done is removed the wire to the “back” (select) button, since it was always on for some reason. Not sure if that’s the root cause.

On a side note, I have another board which doesn’t show up when connected to a PC, I presume that it’s dead?


#2

Did you do a firmware update to the Cthulhu?


#3

Did you wire the other cables correctly?


#4

Yeah, the latest version


#5

Well, the PSX/PS2 Mode of Cthulhu uses 7 of the 8 rows/pins, so it should work with almost everything unless the USB doesnt work too…

Try updating the firmware with the 10ms version, just to make sure the board still works.


#6

Ok, I’ll try that tonight


#7

I’m 99% sure I’ve wired the other cables right. And besides, that’s actually the easiest part. And as pointed out, since the PS2 uses 7 of the 8 connections, the dreamcast one for example uses only pins that work on the ps2 cable. It’s a head scratcher.


#8

Ok, updated to the 10ms version and tried it on the dreamcast and saturn, still nothing. Checked the board with a multimeter and it’s getting 4.5v from the Saturn. To the right pin as well. So I have no idea what it is


#9

shouldn’t it get like 5V? or am i missing something?

does your USB to RJ45 (or cthulhu pins) cable works well? does it have any button shorted? iirc select or start on USB modes usually do POV/XY Axis change for the joystick, but may affect other modes…

i can’t think of anything else now… i hope your multimeter works correctly :slight_smile:


#10

Hey thanks Torta. I would have thought it needed 5v too… perhaps the cable is too long or something?

I have a feeling select was shorted maybe, so I unplugged it. It was always on. It still worked with the PS2 though, either way.

And USB, as in the USB port already on there works on one (I updated the firmware, is that what you mean?)


#11

Every thing except the ps1 and ps2 should be reciving +5 volts. Ps1 and ps2 is the exception at +3.5 volts


#12

Well you might have just found my problem. I’ll look into this.

Thankyou sir :slight_smile: