Datel Arcade Pro stick problem (down-right diagonal unresponsive)


#1

I hope this problem hasn’t been solved yet, but since I couldn’t find anything by searching … here I go.

I recently bought a datel arcade pro fightstick from amazon. The first one I received had a broken button, so I had it replaced. I also noted that in ps3 mode, the stick didn’t respond to the down-right diagonal, only inputting the down direction instead. All other diagonals worked perfectly, and this problem didn’t happen in 360 mode.

I then received another, which buttons worked fine, but the down-right diagonal still didn’t work (only in ps3 mode), so I guessed it was maybe not related to the stick, but maybe to the computer, however when I plug it in a ps3, it still doesn’t work. I guess the problem isn’t hardware since all the wiring looks fine, and it only happens in ps3 mode, but I can’t seem to find what’s wrong.

I’m also reluctant to send it back again, if it’s to receive another one which has the same problem …

Has anyone ever experienced this kind of trouble or any idea on how to fix it ?


SFxT General Discussion #4 - Witty title
#2

Yeah i have the same problem (ps3) and im tempted to smash the shit out of it…


#3

Pics of the wiring. Also, you might want to check if both switches are being actuated when you hit down+right.


#4

I can clearly hear the clicking of the switches, plus I’ve already tried by taking them out and pressing them manually, nothing does … But I really don’t think it’s the wiring since everything works fine in 360 mode …

Here are some pics :


Paewang Revolution (Mayflash) Modding Tutorial ver. Laugh [Lots of pictures]
#5

You mean pressing both the down and right switch at the same time doesn’t register anything?


#6

It registers only down.


#7

I just got it aswell and well, I have the same problem, did you find a solution?

(also, I could do a hadoken from both sides when I tried the trial version of MvC2, not sure on the inputs there but it should be :d::df::f: in that game aswell right?)

this might isolate the problem to SSFIV:AE, not sure at all though


#8

And after some further testing this is what I can conclude:
If I plug it in to my PS3 with the turbobutton to switch the mode to PS3, down-right does not work properly.
If I then plug it into the PC without turbo, it recognizes a “Controller”, and if I try to calibrate it in windows it wont respond to down-right.
If I re-plug it in on my PC with turbo, it recognizes a “XBOX controller” and down-right does respond properly in the calibration panel.

I’m baffled and have no clue on where to continue, obviously the wiring is in order.
What makes me abit more worried is that if I mod it, that was what I had in mind while ordering, how can I be sure it’ll work on my PS3? :frowning:


#9

maybe Laugh can answer your question, I believe the Paewang, Mayflash, and Datel are basically the same.


#10

A customer of mine has the same weird problem :frowning:
I always test sticks before sending them out… even use Zangief to do some piledrivers to check the stick but have done those tests on a 360.
A solution could be to update/replace the firmware but i haven’t come across any updates or updating software. Has anyone tried something like that?


#11

Bump to know if anyone has the same problem or found a solution.


#12

Alot of datels have really sloppy soldering jobs on them straight out the factory and it might be worth checking the underside of the pcb to see if the points that are soldered aren’t touching each other or grounded in anyway.

Having used nearly a hundred of these I have never had this sort of problem so seems very strange.


#13

I’ve also done about a hundred of these pcb’s and also never had this problem but I just finished another stick with the same PCB and having the same result…Training mode doesn’t show the down right corner and just jumps from down to right.

i will check for sloppy soldering but it’s still very weird that it happened in 2 sticks in a row and i’m not the only one.


#14

and the third PCB! this must be a bad batch because i haven’t even attached a button or anything and just touched the wires…


#15

You know what, I just remembered I ordered a load of Datel sticks once and 3 of them from the same batch were faulty as in one of the button contacts never worked at all. In fact I think it was the 4th kick button on all 3 of them. Lesson learnt and that was to test them before dismantling and removing pcb.

Just going back to the actual problem, I find it very strange that it works fine on one system and not the other. I guess it must be a faulty pcb that cant be fixed.


#16

Yeah sometimes i also forget to test them before dismantling :wink:
The problem can’t really be hardware related. It must be a glitch in the firmware i think. Luckilly i used a PS360 in my own stick so after trying 3 paewangs i had to dismantle my own stick to still be able to finish the latest stick.
If i can’t solve the problem, all i can do with these PCB’s is to sell them as 360 and tell the customer that he gets a broken PS3 compatibillity as bonus :frowning:


#17

Found this thread via googling.

FYI it is a bug in the datel PCB.
I use a xbox to ps3 converter now and it works fine.


#18

Cool glad u got it working I used it on ps3 n 360 to make sure it works though and worked