Dead Paewang board? Also some other quick question


#1

So, I’ve already built/modded 2 controllers with a paewang PCB. I’m pretty familiar with them by now, but this last board I’m using seems to be dead, and I’m not sure what can I do to fix it.

When I had it all wired up, I tried connecting it to a PS3 (with the turbo button hold down) to test, but nothing responded. I didn’t even get an “unknown device detected” note.

Since the PCBs start in 360 mode, I decided to try out connecting it to a 360. This time, I plugged it in without holding the turbo button, as well as trying to hold the turbo button to see if the board was on PS3 mode. Still nothing…

As a last resort I tried plugging the board into my PC. When I plugged it in, there was no response at all. I checked the devices plugged into the PC and the board didn’t even show up. Now I’m at a loss for this and I’m wondering if there’s anything I can do with/check if I can bring the board back to life.

Also other question:

  • I’m considering shortening a cable on my other controller with another paewang built into it, but I’m not sure if it’s safe or not. There’s these two little cylinder things that I’m not sure what they’re for; can someone tell me what they’re for?

They look like this -

http://i192.photobucket.com/albums/z177/zetashintani/what-1.jpg


#2

Could be poorly soldered to the board or a bad USB cord, soldering on a different cord should rule those out…

And those are ferrite beads, they reduce interference produced by the cord. Not life-altering to remove, but not a bad idea to have on there either.