Dell Laptop Locked Bios, No Operating System Found


#1

i have a laptop that a friend got from some guy for cheap. Dell Inspirion 1501. Now, when he got it, it was already clear that it had been abused and mistreated. The HD was faulty but it seemed to work. Ran diagnostics, saw the HD was actually in pretty bad shape, but it actually worked well. Anyways, the BIOS was locked, so was unable to change boot to CD to install a new OS. The XP OS already installed seems to be full of viruses, malware and missing a buncha system32 files. Not gonna waste my time even tryin to fix that. So (stupid me) I tried clearing the CMOS. Now when it boots up I get “No Operating System Found”, it will not boot from any CD (drive works fine tho) and the BIOS is locked. Dell, of course won’t help, so its basically screwed. My question to any PC wizards out there: Do I HAVE to open it up and remove the CMOS battery in order to get into BIOS and change boot priority or is there another way? and: Will removing the battery and replacing it after a few hours make it recognize the HD again? it had no problems recognizing it before. Anyone deal w/ this before that can lend a hand?


#2

If you have a floppy disc drive then just try flashing the BIOS. Or just rip that battery out and let it sit over night, won’t know what it does with the HD until you try. It’s already fucked you you don’t have anything to loose.


#3

thx for the replies guys.

gtn, maybe you can help me. I removed the battery, seemed someone had already tampered with it, the clip holding it down was cracked and it snapped off when i removed the battery. I can see it makes contact on the sides. How would I go about keeping it in place? if I press it down it just pops back up of course as the clip is gone. There isnt any space for tape. Would it be alright if I glued it down? at the center it seems to be plastic. (where the battery goes) Or would that cause damage to the battery?


#4

You may be able to slip on some electrical tape, but definitely do not try to glue it on there. That could be very problematic later on…

Either way, you do not need the battery in there to power it on. Just plug it back in and the bios should behave.

For testing purposes try to power it on and see if that gets you anywhere. There is no harm in doing so.


#5

cool, cool. I’ll try these things out. Thanks again, I appreciate the help :slight_smile: