Directional Inputs not registering on PS360+


#1

So I’ve had this issue for not one, but TWO of these PCBs.

Everything else that’s connected (buttons, RJ-45, etc.) works. However, any kind of directional input does not work at all, despite being wired properly.

Things I’ve tried:
-A second PS360+ (which I am encountering the same problem, hence the intro)
-Direct connection from the PCB to the console
-a different wiring harness
-A button wired to a direction (wired to Down and Ground) to see if it was the stick itself
-A different stick lever
-Multiple platforms (PC, PS3, and PS4)

I know it’s being recognized. Otherwise, the buttons wouldn’t work.

There’s gotta be something I’m missing, but I don’t know what. Any suggestions? Everything is connected via the terminals. Would that be the issue?

Picture for reference (Start and Select aren’t wired)


#2

I do not see you have wired up Ground Wire to Ground.
Looks like you wired Ground Wire to VCC instead?

Ground on PS360+ is the next one next to your Green Wire.
I don’t see any wire in the Ground?


#3

…God dammit. It worked.

Time to go to the eye doctor…