Dreamcast Agetec Stick Problem (stuck moving right)


#1

I have a DC Agetec with Seimitsu buttons and the stock stick. Today when I turned on my DC, the stick/curser keeps moving to the right. It does this in-game (any game) and in the Dreamcast main menu. When I move the stick around I get control back (and can move left), but as soon as I let go it moves right again.

I opened up the stick and don’t see a physical problem. The stick doesn’t contact the microswitch when in the neutral position, and the red tab returns out when the stick stops pushing it in. The leads on the PCB look fine, and I opened the microswitch assembly itself and the contact looks fine.

Obviously it seems as if the switch is stuck on, but I can’t tell why or how. I hope it isn’t the main PCB, as I am willing to upgrade the stick to a JLF but finding a new PCB with the VMU slot will be harder. If it is the PCB, what could the problem possibly be? Is there a way to tell if it is the joystick PCB or the main PCB that is the problem? I don’t want to buy a new stick and then have that not be the solution.

Any help is appreciated. Thanks!


#2

I disconnected the joystick PCB from the main PCB (should have done this sooner), and it still registers the joystick right input. So it must be the main PCB that is the problem. Bummer. I don’t see anything physically wrong, such as a piece of wire or solder causing a connection. In light of this new info, does anyone have any ideas what the problem could be, why it happened, and how I could fix it? Thanks in advance… if anyone even looks at this thread…


#3

Bump. Fingers crossed for 1 view.


#4

You can unscrew the screws holding the main pcb to the case, lift it up, check for any foreign debris, screw it down and try again. Also take out the VMU, just in case. Unless you’re ready to get dirty with a soldering iron and multimeter, that’s all you can do at this point. If you do want to get tricky with a meter and iron, say so I’ll try to help.


#5

Thanks Toodles. I already did a visual inspection and didn’t see anything but I’m not very experienced with electronics, so I might be missing something. I already tried it without the VMU.

A friends brother has a multimeter, soldering iron, and is great with electronics. He said he would look at it for me this weekend. I just didn’t want to bother him with it if it was something I could fix, or if it was a common/known problem with DC Agetecs that can’t be fixed without replacing the PCB.

I’ll post the findings here in case it can help someone in the future with the same problem.


#6

Well, the only possible cause and solution I can think of that would be fixable would be if there was a problem with the pull up resistor for that direction. Plug the board in, and connect a resistor (10k-100k ohms) between the power (blue wire of the DC cable) and the Right direction. If the cursor stops moving with the resistor there, verify the stick works properly with the resistor in place, and problem solved. Anything else, I don’t have a solution for.


#7

Thanks again. I’ll try that this weekend. If it doesn’t work I’ll just pick up another Agetec online.


#8

Or you could just put in a new DC PCB.


#9

Are these (actual DC/Agetec PCBs) sold anywhere? I couldn’t find any. If that is an affordable option, of course I would take it. If you can point me in the right direction, I will be greatful. As I have already said, I do not want to use a MC PCB that includes DC because I need a VMU on the P1 slot 1 to load saves. I also like the VMU in the window rather than plugged into an AUX on the plug as some DC adapters have. I also know about Toodles’ awesome boards.

In the meantime, I got my buddy to help me with his multimeter. It looks like the resistors are all fine, but he isn’t sure about the filter capacitor for the ‘right’ input.

Does anyone know the value for the filter capacitors on the main PCB? It doesn’t say on the capacitor itself. If we can determine the right value, that’s about a $1 fix and 5 minutes time. Of course, there is a chance that isn’t the issue, but it’s worth a shot before I buy a whole new Agetec just to replace the PCB… unless anyone shoots me a link where I can buy a replacement PCB (I’ve already searched).

Thanks in advance.


#10

If there is a cap between right and ground, then removing it should cause the direction to start working again. You should be able to hunt down one for the other directions to get the rating for a replacement.