Dreamcast Help


#1

I recently bought a used Dreamcast off Ebay to play Marvel, and I’m having some issues.

Whenever I boot up the DC and try to play, it starts up at a screen with a blue square where I can input the date and time. I try to get past it, but the inputs I put into the controller don’t register. I tried it with a regular DC controller, and with my PS dual-shock stick, using a Total Control Plus converter. Nothing worked.

Whenever I plug in my converter by itself, the little red light on it comes on, but whenever I plug in my stick, it turns off, so it may be a problem with the converter, but really, I just don’t know what’s going on. I don’t have a VMU for it, so that may be the issue, but a friend told me it should work fine without it.

So did I get ripped off or is there something I’m doing wrong?


#2

Check this, I think you got ripped off:

http://www.dcemu.co.uk/vbulletin/archive/index.php/t-9373.html


#3

Depends how much you paid for it whether it’s worth your while kicking up a stink with the seller. He might’ve had it sitting in the cupboard for the last few years and it was working when he last used it, I dunno. He should’ve tested it before selling it though.

Post the link for the auction if you can.

Either way if it’s just the fuse then it should be an easy fix.


#4

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=220241369673&ssPageName=ADME:X:RTQ:US:1123

That’s the link. It was relatively cheap, but $23 is still too much for a broken system that won’t work no matter what.

Does the fact that the LED on the converter lights up whenever I plug it in mean anything? If it is a quick fuse fix, that’s fine, I just need a thread with quick instructions on how to fix it. But, if it’s just because I don’t have a VMU and Dreamcasts don’t read controllers with out them, I can get one really easily.

Edit: Found a site that helped me fix the busted fuse. Works fine now. Thanks to both of you who helped out.


#5

Don’t use a 10 ohm resistor as a fix. Don’t twist the leads as a fix either. That blue resistor looking part(F1) is actually a fuse, maybe 1/2 amp. You can buy PICO fuses which do the same job.

If you have a soldering iron, put a fuse holder in its place:


#6

http://forums.shoryuken.com/showthread.php?t=130932

That might help.


#7

Told you he had it in the cupboard for ages :razzy:

He also states that the controllers don’t work (or malfunction as he mentions) but it could’ve very well been the port, in which case it is.

I’d use one of those resettable fuses like Toodles mentioned (he knows his stuff) so if ever something happens again, you just have to wait until it resets. No need to open the DC and crank up the soldering iron again. :smokin:


#8

Thanks a lot guys, DC works fine now. I initially just twisted the fuses together until i could get a hold of a soldering iron and get a new fuse in there. Now it’s perfect, so hopefully it doesn’t blow again.