Dual modded 360 TE issues: An ongoing affair


#1

I ask time and time again and I’ll ask again to hope someone can help me find the answer to this riddle. I really enjoy using my stick and want to fix this problem. I’ve thought about just buying another TE, but default TE pcbs have the tendency to have the same problem, so no point in wasting money.

I’ve got my 360 TE dual modded with an imp and a cthulhu and every once in a while out of the blue moon I get a please reconnect your controller message that pops up and goes away after a few seconds leaving the stick dead for a few seconds.

I’ve ruled out faulty TE PCBs because I’ve replaced it with a madcatz fightpad pcb.

I’ve ruled out USB cable problems because I’ve replaced three different usb cables.

I’ve rewired everything several times to rule that possibility out.

I don’t know what could possibly be the problem at this point. Perhaps the imp or the cthulhu? I was dead set in believing the 360 can’t handle dual mods but people swear night and day that their sticks have been dual modded for years without any issue.

Can anyone give me any input on what the problem could be? I’ve switched almost everything out of the stick with no answer. To me it looks like its shorting itself out. Perhaps the SE/TE/Fight pad pcbs just can’t handle dual modding?


#2

The 360’s USB ports could be faulty. Try playing on a PC for a while and see if you get any random disconnects.

If you still have problems on a PC, replace the Imp with a DPDT switch to see if the Imp is faulty. If the DPDT switch doesn’t solve the problem, then the Cthulhu is the source of the issues.


#3

I’ll say it one more time and this will be the last. Its not the imp, dpdt switch, cthulhi, or the madcatz sfiv fightpad pcb that is causing all the problems. Its the madcatz sfiv 360 TE pcbs that is. The 360 TE pcbs was not made with love. There TE 360 pcbs are shit period. I have a dual modded stick with a madcatz sfiv 360 fightpad with cthulhu+imp no problem what-so-ever.


#4

i’m not even using the te pcb. I’m using the fightpad. I guess my stick is haunted.


#5

If it was anything it’d probably be the imp board.


#6

First off, the Cthulhu IS NOT the problem. Its a completely independent board, and unless you wired something totally ass backwards, it shouldn’t have any effect on what happens when its plugged into your 360.

With that being said,

Get out the multimeter and check the USB wiring connections (5v, +D, -D, G) on the fightpad, like physically touch a lead to the 5V and then one to the imp board/cthulhu/usb cable and make sure its a solid connection.

If ya see this, Markman, you did some great shit with the TE sticks, but sadly that same love wasn’t given to the actual creation of the fightpads. The one that I used for my Dual Mod kinda went berserk on me, but that could have actually been from a variety of things.

ANYWAYS, if the USB connections are all great, then the next thing to do is to check the continuity on your IMP board. make sure the connections are all good. If all the connections are good on the IMP, then it could be your 360.


#7

I’ll see what I can do, but this has happened on different 360s. Where did you happen to get that fightpad quote?


#8

That was from your post. I just use a lot of forum coding and what not.


#9

have you used a multimeter to check every solder point? On occasion i’ll have one solder point with a thin fray causing a short every now and then. Usually the problem.


#10

Talking about the italicized quote of fightpad pcb going berserk. I’m going to check my points with a multimeter now. If everything is ok I’ll probably get another IMP.

I don’t see what else it could be if I’ve been through so much.


#11

It was italicized since it didn’t really pertain to this thread

But it was the fightpad I used that 187’d


#12

I ran a continuity test with my multimeter on the 5v, d-, d+ and ground signals of my fight pad and cthulhu to the d1 and d2 points. They all have a solid connection, but when I had my multimeter on the d- and d+ on either the fightpad or the cthulhu I noticed that any other signal I touched emitted a small signal.

I don’t really know too much about the mechanism of the electronics, but I know my solder spots are on point. I did that d- and d+ check on other pcbs I had laying around and it did the same thing

Any advice?


#13

Just a more detailed post for anyone who is interested to read it.

Seven months in the making… I’ve eliminated all trigger issues by switching to the madcatz fightpad pcb but I am still getting intermittent “please reconnect your controller” messages that pop up for effectively 2-3 seconds and then go away. The result is that the controller is not functional or recognized during that time.

The situation here is obviously a power issue. Something seems to be getting shorted out. With that said, I can only think of these variables involved with power.

1- USB Cable
2- PCBs involved
3- IMP Switch
4- Wiring
5- USB port(s)

I feel confident in saying I have eliminated 3 or 4 out of the 5 variables I have mentioned.

This list represents what I’ve done with my stick.

Replaced USB cable:
1-Used original TE Cable
2-Used a replacement TE cable sent to me by madcatz
3-Currently using the shorter madcatz Fightpad cable

Replaced PCB:
1-Used original TE PCB
2-Used a replacement TE PCB sent to me by madcatz
3-Currently using the madcatz fightpad pcb

Wiring:
I’ve rewired at least three times and used completely fresh wires due to getting new pcbs involved. I’ve used an analog multimeter to confirm my 5v,d-, and d+ have a complete signal to the imp.

USB Port:
I’ve switched to different USB ports on my xbox and have played on other peoples xbox 360 and have had the same issues. Have not tested on PC as I don’t play many games on there. PS3 also does not have such thing as a please reconnect your controller message, so I cannot confirm whether or not this happens on the ps3, but I have not had any controller intermittent problems. This problem happens so randomly and is impossible to reproduce.


Untested variables include:
Cthulhu
Imp Switch

I’ve come to these theories.

1- Imp: Switch may be faulty. I’ve contacted toodles about his thoughts but he hasn’t replied. I have people (mds72582) who try to tell me its impossible for the imp to be the issue at hand, but I honestly DO think it can be a faulty imp board. Just wanted to note that I’ve talked to ShinJN who also has this “please reconnect your controller” issue but uses a dp/dt switch. This is one of the things that lead me to believe it’s not an IMP issue, however, he does use the original TE PCB and those have been said to give off the controller issue on non modded sticks, so there’s a possibility his pcb is faulty from the get go.

I have yet to try a different imp board because I’ve spent so much time and money that I really need someone to convince me whether or not that is the issue to order a new one.

2- Cthulhu: I seriously doubt anything is wrong with the cthulhu. Possible? Yes, but doubtful. I really can’t exclude this out of the equation though.

3- USB ports cannot handle dual mods? I know people have had successful dual mods and have no issues what-so-ever, so this theory can probably be knocked off the bat right away. I still have to include it just for my sake.


So this is my compiled list and I have nothing else to really say or add. At this point I’m debating if I should just buy another stick to avoid the hassles of dual modding but I really love my current stick and would really like for it to perform the way it should.

Any additional help or suggestions that you guys can offer will be appreciated.


#14

I want to add that I’m getting the same issue on my end with a dual-modded TE. I’ve gotten it to a point that I can reproduce the issue in a semi-reliable fashion by performing a quick clockwise down to up motion with either the bottom left or the next button to the right (sorry, I don’t have the stick in front of me to confirm the actual button labels). The stick will then disconnect by itself and come back shortly. I don’t believe it has to do with the 360 USB port, as the same thing occurs on my PS3 as well. Aside from checking the wiring on a basic level, the one thing that was suggested to me was to replace the stick itself in case the PCB attached to the wiring harness was fouling things up. I did that and it worked fine for a bit, then it started screwing up again.

Someone else did the mod for me, but I believe I have a dp/dt switch (I’m assuming this is what it is? it’s a switch that toggles the stick between PS3 and 360 mode). I don’t have the tools to properly check continuity, but I get the gist that this is a problem with the Madcatz PCB, at least on my end. My Cthulhu was working perfectly prior to the dual mod and I’m considering just attaching a USB cable to that board in order to keep the damn thing working at least on PS3. This is incredibly frustrating to deal with because I love the stick otherwise.

Is it even worth exploring the option of replacing the Madcatz PCB with another one? I want to get past this as painlessly as possible, if I can even do this…


#15

Bernie, your issues seems to be a wiring one, though. Specially if it happens on both the PS3 and 360. If possible, have someone take a look at the wiring for any shorts first rather than spending more money on a replacement PCB.

As for the OP, I think you can eliminate the Imp and Ctulhu entirely by removing the dual-mod for awhile and playing with the TE PCB only. If the problem happens then, then there you go, the TE PCB is at fault.


#16

My issue sounds like the exact same issue the OP has - how is this a wiring problem? When I replaced the stick, it magically worked perfectly for a few hours. Then the problem came back, same as it did before. I did nothing with the wiring aside from plugging in the 5-pin harness when I changed sticks. Like the OP, I also think it’s a problem with the power, but I don’t have the tools or skills to confirm this.


#17

I can’t reproduce the issue like you said. I’ve tried shaking the stick around and moving the pcb as a way to check the connections.

Yesterday I took a multimeter and checked that way. I have no soldering issues here. I talked to ecksnine who has also experienced these issues throughout his stick building career. He said that he thinks the madcatz pcbs are just crap. I don’t really know what to think at this point since I’ve been through three of them. Perhaps madcatz pcbs just aren’t reliable for dual modding… i don’t really know what else to say. I know there are people with successful ones also.

Toodles replied to me and told me he doesn’t think it’s the imp.


#18

If no one can find any solutions, perhaps a set of pictures would help


#19

I’m guessing it is the Madcatz PCB. Their shit in general is pretty shoddy. I have a stick that had that problem but it went away. Even had a Madcatz retro arcade pcb die on me for no reason, and that soldering job was all clean and proper. Now I know where that $10 in savings in a 3rd party controller went.


#20

i’ve been using 30 gauge solid wire. I’m going to go ahead and switch to stranded to see if it helps at all.