Easy Fix for Madcatz SE Buttons


#1

Need a fix before getting your Sanwas/Seimitsus/ILs? The below method has worked for me 100% of the time with over 16 buttons.

Everyone pretty much reports that one or two of the original SE buttons sticks. This is obvious if you test each button by pressing the outer edge of the plunger – it will not go in smoothly and pretty much just struggle on the way down.

For most of the time, I always just assumed it was a crappy switch – the Madcatz switch is after all quite different than the Sanwa switch. However, after some accidental testing I found out that the switch isn’t entirely at fault.

A stuck button that I opened up appeared to be perfect on the inside. Using my finger to depress the switch at an edge did not cause a problem – I assumed it was just the shape of the switch afterward. Wrong again. When I replaced the plunger, all of a sudden the button worked perfectly – and I mean perfectly.

What’s wrong with the button then? It’s probably a wild guess, but I think the plunger pegs are too far out, or placed uncentered on the switch. Depressing them with a flat head seems to push them in a bit permanently. Pressing the button at most angles proved to be smooth afterward.

**TL;DR: **

  1. Take the plunger out of the button by depressing the two little levers on the side of the plunger.

  2. Twist off the micro switch (counterclockwise) at the bottom.

  3. Put each back in any order.

Optional: Spray a bit of Silicone lube at the edge of the white switch. You may find the lube to be handy for fixing the stock stick as well (squeaky switches/spring). I never did this.


#2

I just received an SE madcatz, and right out of the box, my jab button had a problem. It doesn’t stick, but it’s unresponsive :frowning:
It randomly won’t register, and if it does, I feel a huge delay. I opened it up on the back and checked the connectors, but there’s no issue. I think it’s the button itself because it feels different. It doesn’t feel as “clicky” as the other ones and it depresses a bit too softly.
What do you think I should do?


#3

swap it with one of the extra two buttons on the right.


#4

open up the back, and “twist off” the actual push portion of the button. (black and connected to leads)

pry open the black part gently and you’ll see a spring (gently or this spring and ball will fly out), ball bearing and 2 prong leads inside.

I slightly squeezed these prongs together and my FP works 100%. if you dont know how the reassembly used to look, pry open another button and see. i used to have your same problem.

Gl


#5

Thanks fellas, I’ll try that out.


#6

Mettleh3d…I had the same problem and tried your suggestion. It worked! Just wanted to add a couple of details to the procedure.

After you remove the back plate, you don’t need to disconnect the terminals from the button. Just grab a hold of the black part in the middle of the button and twist it counter-clockwise to remove it. To separate the black part, you need the use your finger nails to gently lift the two tabs that hold it together. While they’re lifted, carefully pull the assembly apart. Don’t let the spring jump out. As you slowly separate it, take note of how it goes together so you can re-assemble it properly. When you see the terminals, don’t push them too close together or the button will be a bit too sensitive.

Thanks for the tip Mettleh3d.


#7

As far as the TE stick buttons go, I feel as if they’re too “soft.” If I wanted to replace them with something more firm, what would suggest? Would I have to make sure that the new ones are 30mm AND snap-in? or can they be screw-in also?


#8

Any 30mm Seimitsu will do. The screw ins will have a little difficulty with the A(360)/X(PS3) button but not much of a big deal. For A you have to put the nut there first then screw the button in from the top due to the mounting plate.


#9

So you’re saying the parts (microswitch, plunger, housing) are all fine and defect free, but the problem is that they were either assembled poorly/incorrectly, or knocked around so it was incorrectly set in transit?

I’ll check it out. Thanks for the suggestion, I hope it works.


#10

Just slide the nut under the mounting bracket and screw from there.