[fixed] Fightstick is "Unkown device"


#1

Hi guys,

I’ve bought the Datel “Arcade Stick Pro” to test if I can play with a fightstick. Normally I play with an Xbox 360 pad and that was just plug and play. Never had any probs with the Xbox pad.
However my PC (Win7) doesn’t recognize the stick. When I put it into my laptop it gets recognized as “Arcade Stick”.

I’ve searched the internet for some time and haven’t found anything that works.

The stick is the following:

I’ve tried so far:

  • XBCD 0.2.7 (Stick didn’t show up)
  • Hold the Turbo button (didn’t change anything)
  • Install Microsoft Xbox 360 Drivers (no change)
  • Tried USB 3.0 and USB 2.0 slots (always “Unknown device”)

Why does it work in my laptop which also has Win7 but in my PC it only shows as “Unkown device”?
The company has no drivers for the stick because I should be recognized by the PC automatically.

Thanks for any help!

Best regards,
Turbo


#2

If it is anything like the early madcatz sticks it will probably be an issue with the motherboard chip type, for instance in early Madcatz sticks the controller would show up on the computer but it would not register any directions, some people used VIA USB chipsets to get them to work.


#3

You need the Joytron Paewang Revolution driver.


#4

Does somebody know where I can dl it?
The website from Joytron seems to not offer any drivers and google doesn’t help either.

Edit: Updated the first post with my solution.