Game Controllers in Control Panel does nothing


#1

I’ve been having this issue for a while now. The Game Controllers program in my Control panel does do anything. I double click it the hour glass comes up, then nothing. This doesn’t seem to prevent me from using controllers in games, but it’s getting really annoying since I have to plug into another computer to check button functionality. Also I don’t know just what number controller each controller/stick I plug in is being assigned.

There seems to be very little about this online. I’ve tried uninstalling other usb devices on my system, and I still get nothing. Any ideas? I’m certainly not reinstalling my entire OS.


#2

what type of windows do you use?


#3

Try different USB ports


#4

XP Pro SP3 32bit


#5

Are the drivers for the controller installed on that system (from a disc or online)?


#6

It’s not a driver issue, as it doesn’t matter what controller is plugged in,the application simply does nothing.


#7

Try this:

Start > Run > type in “services.msc”, and look for these two services:

  • Plug and Play
  • HID Input Service

If either or both are not labeled as “Started”, double-click them, and set them to run Automatically, and start them. If they’re both running, there may be a serious issue with those services.


#8

Both are listed as started and automatic.

My controllers, sticks, all other interface device still operate fine on my machine. I just can’t seem to start up the Game Controllers application at all. I had to take a pen and paper and write down the numbers for my button input from plugging into a computer upstairs. After that I was able to map just fine.

I’m thinking there’s an issue with joy.cpl in my system 32 folder. I once attempted to replace it with the same file from another XP Pro system but that just gave me an error.