Gamepad problem: half my buttons work


#1

years ago I bought a snes/nes retro kit from retrousb.com. i opened my factory snes controller, snipped the cable, and soldered the new chip in (which was already attached to a usb cable). the pad has been 100% plug-and-play and 100% reliable, till now. it has worked flawlessly on every nes, snes, sega genesis, ps1, n64, gamecube, gameboy, gameboy advance, and arcade emulator i have ever run. i plug in the controller, and see the device success pop-up in the bottom right (windows 7 x64). i even go to the windows gamepad config menu and calibrate and test the controller, and everything works perfectly and accurately.

(retro usb snes-kit link: http://www.retrousb.com/product_info.php?cPath=21&products_id=44)

i run ssf4ae in steam. i go to the button mapping page, cycle till i see the RETR page (for my retro usb gamepad), and start inputting my desired button mapping. half the buttons work fine: Dpad, select, start, Y, B. but when i try to map X, A, R, L to the desired commands, ssf4 doesn’t register that I’m pressing anything at all.

anyone have any insight or suggestions? (other than “get a stick” :P)

thanks so much in advance! i’m new here. just bought ssf4ae on steam. buddy got a copy too. i’m excited to get into it! i always liked fei long when i used to play ssf2t but his moves were too hard… anyone try sirlins hd remix? easier commands, hd graphics, rebalanced moves (safe frames, startup frames, hitboxes, etc). very good.

TL;DR - windows 7 sees all my button inputs. ssf4ae only sees half or so. omgwtfbbq.

-mike


#2

Have you attempted to use Xpadder or DS3 tool to provide a middle ground for the device to place inputs into SSF4.
Personally, I use DS3 tool for my fightpad only because it’s easier to make it think I’m using an Xbox controller (yes I have it on pc too)


#3

if what wickedzero say dont work, map all to keyboard a use a program like joytokey to use the pad like a keyboard.


#4

thanks for the support!

i tried ds3 tool and couldn’t really get anywhere with it.
i tried xpadder but couldn’t get ssf4 to recognize any gamepad
i tried joytokey, which actually worked great, but doesnt recognize button releases as commands :frowning:

i’ll just use my n64 usb converter, which works fine. n64 pad has 6 face buttons anyway.

thanks again everyone!

-mike