Gamesforwindows live: cant connect


#1

perhaps anyone of you can help me out here :frowning:
desperate situation for me…

system: vista x64 sp2

error codes:

what i tryed so far:
vista & router mtu set to 1500
tcpip stack reseted via cmd command
ports opened: 80, 3074, 6881, 53, 443, 88, 1024
.net 3.5sp1 installed
even tryed one hint where someone said you should delete all your usb devices … didnt help either.

it still cant connect.
so how can i solve this?

(btw if i open just the client it connects without any problem, just ingame it cant connect. another note: when i enter wrong details the system doesnt accept them - so it can check logins but does not go on…)


#2

if you mean the one from december 2007 http://go.microsoft.com/fwlink/?LinkId=98609 which is the last one the support site (http://global.gamesforwindows.com/de-DE/support/webSupport.aspx), yes.

edit:
saw something new (from the log):

Live Logon Failed

00:B9:49:F0:B0:* < is that the mac of the adapter it uses? that mac does not exist … it uses the correct ip but a wrong mac

does it use its own virtual adapter or is this the overall problem? how can i fix this?


#3

^ actually there’s a recent update (couple days ago). It should have prompted you once you had attempted logging onto GFWL when launching SF4


#4

nope i get nothing. if i enter my login, it downloads my profil and then fails to connect.

[edit]
lol @ negative rep for this thread … too bad you cant see who that fucker is …


#5

try uninstalling gfwl and reinstalling?


#6

didnt help :sweat:


#7

try this link and d/l the update and install. hopefully this helps

http://www.microsoft.com/games/en-us/aboutGFW/pages/gfw3intro.aspx


#8

the download leads to the same file as i posted before.


#9

From what I gathered from your post history, you look like you’re somewhere in Europe (is that right?)

The support for Games for Windows is limited by country. Is it by chance you’re just not in a supported country?

http://www.xbox.com/en-US/live/countries.htm


#10

ya thats true im from .eu and im in a supported country.


#11

A friend of mine had the same problems. Turns out he had an extra LAN connection installed (to VPN to his work) and the game or GWFL tried to use that to connect instead of his actual internet connection.

So just disable every LAN connection in your Control Panel, except the one you use to connect to the internet. Should work then.


#12

Well I had the same problem and disabling my firewall helped.


#13

@limecrabdude
no firewall running.

@Jehjoa
already did that. didnt help.

i have noticed something different now: ingame you can select more options -> it shows something like “network status: X.X.X.X:0”. X=IP 0=port … as far as i know 0 is not a valid port. i know that i can change it via registry but this does not take effect in the (ingame) config.
the wrong mac is also still present and i have no idea where its from (checked all present devices and reg for it).


#14

Do you use proxy in internet explorer? GFWL uses IE proxy settings. I had my IE proxy set wrong and MSN Live, GFWL, IE, Yahoo Wdigets etc. didn’t connect but Firefox was working correctly. It drove me nuts until I figure out this.


#15

nope no proxy set and ie is working.

[edit]
problem solved. cause of all this was a router firmware bug which existed since 2005 and was never fixed (some ports cant be forwared even if set in config). a beta firmware solved it :slight_smile:


#16

i think you may have overdone the troubleshooting and made things worse!

are you on Steam? did you make a backup? i would try to reinstall it, but it sounds like you may have went in too deep :wow: