Gamestop xbox wired controller acting strange

hi, just got this new (old) xbox 360 elite (manufactured 2009)

my stickless has pc/ps3 cthulhu + that 7400 socd cleaner from that thread, so it won’t work with that xbox

decided to cannibalize an old but perfectly functioning (on pc at least, no i didn’t tried it on the xbox first because they told me was xbox-only when i bought it) gamestop-branded xbox wired controller to make it work with pc and xbox

after i finished soldering i tried in windows controller panel, all was working as intended

i used x y a b l1 r1 l3 r3 to not mess up with the triggers

menu navigation is ok

tried to start 3rd strike online, configure buttons is nearly ok (won’t let me use l3 and r3)

during the play “a” button does not work sometimes even “b” doesn’t work (depends on the configuration)

pressed home and tried to navigate the menu and suddenly they’re all ok, tried to reconfigure and all buttons responds correctly (not l3 and r3 but whatever)

i tought it can be a game bug, so i tried virtua fighter 2 and same story

someone has an idea on this, can it be the gamestop controller poorly supported by games in general but not the xbox?

here’s a photo of the controller:

http://i.imgur.com/4urPWjo.jpg

http://i.imgur.com/kca99lM.jpg

I suspect that you need to test it some more in the Windows controller panel and see what comes up. My guess is you’ve got a faulty connection, either at the solder joint, or at the button.

How if your wiring? Can you produce pictures of how your wired the PCB.

Also keep in mind, only the older Mad Catz Gamestop Controllers are common ground
PDP made controller is OFTEN not common ground, meaning each button contact needs 2 wires, one for each side going to each button

Set pics first as sometimes a 2nd set of eyes will spot something you might of missed.

shame on me it’s (almost) ok now

one of the two triggers’ potentiometers wasn’t in neutral position that caused the problem

now i glued them in neutral

also i have a madcatz fighting pad somewhere, maybe should try with that instead to have all the buttons working properly

Well post the picture of the PCB you are currently using and its wiring.
No need to tear up another pad if we can get the existing one working…

Lets get a 2nd set of eyes on it first, even if its messy. Don’t worry I seen some badly done wiring in my day.

You’d think I would have suggested you check your triggers, since the same thing happened to me…

http://www.reactionface.info/sites/default/files/imagecache/Node_Page/images/1314029819767.png

Ok thanks, i’ll post some photos later

here they are

http://i.imgur.com/rHJJhNb.jpg

http://i.imgur.com/ax4j3Ce.jpg

its hard to tell in your photos. and its especially hard to tell with the new lead free solder the EU pretty much forced the world to use.
But it could be possible you have cold joints for your soldering, I would also use the actual pad contacts instead of the test points.

Also double check that your PCB is common ground or common line

man, no need to check soldering, the pad works, i tought you wanted to tell me how to use analog triggers instead of l3 r3, because those aren’t mappable in some games

I don’t know any fighting games that actually use L3 and R3 other than Sony’s Playstation All Stars

Yeah they are hackable. On both analog sticks, on the rigth side, see the tac switch? Those are you L3 and R3.
You can tap into there contacts on the reverse side of the PCB.

But that still do not fix your buttons not working in your games.

I already hacked l3 and r3 successfully, but realized that those are only configurable on pc

i meant rt and lt, they have a potentiometer (the ones i glued) each one, and can’t be replaced with a contact only

thanks i’ll give it an eye