Getting a TE to work with MAME


#1

ive been trying to use my Xbox360 TE for MAME but cant get it to work for some reason, while trying to configure the controls it wont register any inputs from the TE, ive tried the TE on other emulators on the same computer and it works perfectly.

ive also tried a wired 360 controller in MAME on the same comp and it works fine as well, and my Kitty modded TE works fine with it as well, but only if its not in 360 mode, any ideas on what it could be and how i could fix it?


#2

What setting the joystick selector switch is set to. LS, DP or RS?

Set it to DP.

Kitty modded TE works fine
Stick to the Kitty, you already have your solution. Any ways for some reason MS wants the LT and RT receive as a single axis instead of 2 buttons, kitty fixes that.


#3

I have a TE and I had absolutely no issues with it when my friend and I played used MAME on his netbook. Just plugged in, Windows downloaded the drivers, config’ed my stick and we played.


#4

I had trouble but I looked at a few threads and they suggested using Xpadder. Works fine now.


#5

I’ve had trouble getting my te working for mame it won’t read any input including my buttons. But my te works fine on ggpo


#6

thanks, xpadder worked


#7

irony. I just put mame on my computer and it won’t recognize my TE. haha.


#8

my ps3 rnd1 TE and ps3 MVC2 TE sticks worked fine with mame and my X360 rnd 1 TE had issues and had to use xpadder.

but now I have mame on Xbox1, and both rnd1 TE’s have had their pcb’s swapped with PSOne dualshocks, much better, can now use them on everything with a converter, except my snes


#9

i found that the my TE didn’t work in certain versions of mame for example, it didn’t work in the newest 0.143 version. But it did work in other versions like 0.126 through 0.134, you should try and see if those versions work for you , rightnow im using version 0.126 and i can use my TE perfectly. u can download other versions here http://www.progettosnaps.net/mameui_en


#10

Note remember to go into OPTIONS on mame and turn joystick enabled in default game options or it wont work :wink: